Version 23 (modified by amain, 7 years ago) (diff)


See MinimumRequirements to see what is needed to get DebWrt running on your devices. If your device if not on the list below, but supported by OpenWrt and meets the minimum requirements, then build DebWrt yourself using the DebWrtSvn build environment.

This page is mainly maintained by users. Please add your device to this table and let other users know you got DebWrt running on it. Create a link to the OpenWrt hardware description page of your device and create a DebWrt wiki page with installation instructions, problems encountered, compile instruction, which images to use, post configuration, etc.

Supported Yes = device is supported by the DebWrt team
User = user got it working
Version Works / tested with DebWrt version n.m

Latest release
User contributed images

Manufacturer Arch Device name Wiki Version Supported Comments
Asus mipsel WL-500g DeLuxe AsusWl500GDeluxe >=1.0 Yes
Asus mipsel WL-500g Premium v1 AsusWl500GPremium >=1.0 Yes
Asus mipsel WL-500g Premium v2 AsusWl500GPremium >=1.0 Yes
Asus mipsel WL-HDD 2.5 AsusWlHdd25 >=2.0 Yes
D-Link mipsel DIR-320 DlinkDir320 >=2.0 User
Linksys mipsel WRT54GL LinksysWRT54GL >=2.0 User Mod required
Netgear mipsel WGT634u NetgearWGT634u >=2.0 User
Netgear mips WNDR3700 NetgearWNDR3700 >=2.0 User
Mikrotik mips RouterBoard 450G MikrotikRouterBoard450G WiP User
Ubiquity mips RouterStation RouterStation >=2.0 Yes
Ubiquity mips RouterStation Pro RouterStationPro >=2.0 Yes