Version 7 (modified by anonymous, 8 years ago) (diff)

--

LINKSYS WRT610N-V2

The linksys WRT610N-V2 is now supported on debwrt, at this time no images will be provided. You must compile for yourself using the plugin included below.

Please note that the broadcom gmac driver is not covered by a GPL compliant licence. Use of it in any way is done so at your own discretion.

See thread here for support discussion.

Compiling From Source

Follow instructions here with a few modifications:

  1. After checking out the DebWrt Build Environment, download and extract the attached archive to the plugins directory. brcm4716-plugin-3.0.3-040911.tar.gz
  1. Follow the rest of the instructions as shown on the above link.

General notes about the modified source files (the ones in the above archive)

  • The new plugin facility automatically patches the DebWrt config files to create brcm4716 based device targets as well as select all required packages and options.
  • Other brcm4716 based devices which are supported by the plugin include the Linksys E3000-V1 and the Asus RT-N16.

*AT THIS TIME ONLY THE RT-N16 HAS BEEN CONFIRMED TO BE WORKING, IF YOU HAVE SUCCESS ON EITHER THE WRT610N-V2 OR THE E3000-V1 PLEASE POST YOUR RESULTS IN THE FORUM*