Modify

Opened 6 years ago

Closed 6 years ago

#9988 closed defect (invalid)

Build fails when assembling modules for rootfs (?)

Reported by: Evengard Owned by:
Priority: major Milestone: milestone:trunk
Component: buildsystem Version: trunk
Severity: severity 4 Keywords:
Cc:

Description

When building (probably at the rootfs stage, but unsure), the process fails.
Log: http://pastebin.com/raw.php?i=hhf1ryUc

Attachments (5)

config.debwrt (24.1 KB) - added by Evengard 6 years ago.
DebWrt .config
config.openwrt (38.9 KB) - added by Evengard 6 years ago.
OpenWrt config
openwrt.diff (6.0 KB) - added by amain 6 years ago.
headers.txt (3.3 KB) - added by amain 6 years ago.
log2.txt (44.8 KB) - added by Evengard 6 years ago.

Download all attachments as: .zip

Change History (19)

comment:1 Changed 6 years ago by amain

Tried to reproduce on trunk r573. Selected target: CONFIG_TARGET_brcm47xx_Broadcom-bgmac-none=y. However, no build issues. What changeset did you use? Any other differences?

comment:2 Changed 6 years ago by Evengard

Well, I activated kexec, brcmsmac module, bgmac module compile into kernel, some led modules... That's all I think.

I'lll try to attach my .config files a little bit later

Changed 6 years ago by Evengard

DebWrt .config

Changed 6 years ago by Evengard

OpenWrt config

comment:3 Changed 6 years ago by Evengard

configs files added

comment:4 Changed 6 years ago by amain

cp config.debwrt to .confg
make menuconfig
make openwrt/prepare
make all

Build just fine. So issue must be in config.openwrt.

Changed 6 years ago by amain

comment:5 Changed 6 years ago by amain

  • Resolution set to wontfix
  • Status changed from new to closed

Diff between the generated config following above procedure and config.openwrt shows quite a few changes. Notably the use of EGLIBC instead of UCLIBC.

Not going to investigate further. Please use UCLIBC.

comment:6 Changed 6 years ago by anonymous

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Without eglibc it is unable to cimpile full language support. See https://dev.openwrt.org/ticket/13095

Anyway before the last changes it worked with eglibc without problems. Why that could be the problem?

comment:7 Changed 6 years ago by Evengard

I'll try to compile with uClibc when I'll be at home, leave reopen for now please.

comment:8 Changed 6 years ago by amain

Ok. Will leave open for now.

Changed 6 years ago by amain

comment:9 Changed 6 years ago by amain

Used both your config.debwrt and config.openwrt and produced a clean build. See headers.txt. Even with EGLIBC. Seems something local to your system. Sure you have latest DebWrt?

Changed 6 years ago by Evengard

comment:10 Changed 6 years ago by Evengard

Weird, because I got the same error with uClibc. Debwrt is the latest one, build environement is clean... The build environement is debian wheezy inside VirtualBox?. Attached the log.

comment:11 Changed 6 years ago by Evengard

Tried checking the debwrt from SVN from scratch and complete rebuild - And i get the same error.

comment:12 Changed 6 years ago by amain

That is nasty. I can't help if it is not reproducible. Do you have some makefile skills? It seems to go wrong in the kernel source tree:

cd /home/evengard/debwrt/build/openwrt-brcm47xx-Broadcom-bgmac-none-trunk-HEAD/build_dir/target-mipsel_mips32_uClibc-0.9.33.2/linux-brcm47xx/linux-3.10.21 && make headers_install ARCH=mips INSTALL_HDR_PATH=/home/evengard/debwrt/bin/brcm47xx-Broadcom-bgmac-none-testing-2.1-1/openwrt/headers/usr/src/linux-headers-3.10.21

You could try running the exact command manually and see what it says. Also an export LC_ALL=C would be great, cause the error messages are in an unknown language to me. If that doesn't help, do some debuging on the headers_install target. Note that there have been some patches by OpenWrt regarding modules install. Not directly related, but also not unrelated. See: http://dev.debwrt.net/ticket/9987#comment:3 and follow link to OpenWrt Trac for more info.

comment:13 Changed 6 years ago by Evengard

Well, time to close it as a "notabug" that time. The problem was that I was running make -j 5. It works bad with "-j 5", without it it seems to be OK.

comment:14 Changed 6 years ago by amain

  • Resolution set to invalid
  • Status changed from reopened to closed

Thanks for the final feedback. Glad it works. -j n indeed doesn't work predictable.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.