Modify

Opened 8 years ago

Closed 7 years ago

Last modified 5 years ago

#98 closed defect (worksforme)

Kernel Panic: No init found

Reported by: crodr021@… Owned by: amain
Priority: major Milestone: milestone:
Component: buildsystem Version: 2.0
Severity: Keywords:
Cc:

Description

Routerstation pro board, getting

Kernel panic - not syncing: No init found. Try passing init= to kernal

Attachments (0)

Change History (24)

comment:1 Changed 8 years ago by stappers

Tell more about the disks ( storage devices ) that are used.

  • how many
  • how many partitions
  • what kind of file system (vfat, ext3)
  • what is in the file system

comment:2 Changed 8 years ago by crodr021@…

I followed the installation guide:

http://dev.debwrt.net/wiki/DebWrtInstallation

comment:3 Changed 8 years ago by anonymous

kingston 4gb SD card

comment:4 Changed 8 years ago by crodr021@…

 .
 .
 .
uhci_hcd: USB Universal Host Controller Interface driver
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
 .
 .
Waiting 15sec before mounting root device...
usb 1-2: new high speed USB device using ar71xx-ehci and address 2
usb 1-2: New USB device found, idVendor=05e3, idProduct=0723
usb 1-2: New USB device strings: Mfr=3, Product=4, SerialNumber=2
usb 1-2: Product: USB Storage
usb 1-2: Manufacturer: Generic 
usb 1-2: SerialNumber: 000000009451
usb-storage 1-2:1.0: Quirks match for vid 05e3 pid 0723: 8000
scsi0 : usb-storage 1-2:1.0
scsi 0:0:0:0: Direct-Access     Generic  STORAGE DEVICE   9451 PQ: 0 ANSI: 0
sd 0:0:0:0: [sda] 7741440 512-byte logical blocks: (3.96 GB/3.69 GiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Assuming drive cache: write through
sd 0:0:0:0: [sda] Assuming drive cache: write through
 sda: sda1 sda2
sd 0:0:0:0: [sda] Assuming drive cache: write through
sd 0:0:0:0: [sda] Attached SCSI removable disk
EXT3-fs (sda1): recovery required on readonly filesystem
EXT3-fs (sda1): write access will be enabled during recovery
EXT3-fs: barriers not enabled
kjournald starting.  Commit interval 5 seconds
EXT3-fs (sda1): recovery complete
EXT3-fs (sda1): mounted filesystem with writeback data mode
VFS: Mounted root (ext3 filesystem) readonly on device 8:1.
Freeing unused kernel memory: 180k freed
Failed to execute /sbin/init.  Attempting defaults...
Kernel panic - not syncing: No init found.  Try passing init= option to kernel. See Linux Documentation/init.txt for guidance
Last edited 8 years ago by stappers (previous) (diff)

comment:5 Changed 8 years ago by stappers

So there is a root filesystem found on /dev/sda1, but no init in it.

Take the storage device from the debwrt hardware and mount in on a GNU/Linux system.
Check there manually for init.

Something else, what is the workaround and/or fix for #97 ? Feel free to update that ticket.

comment:6 follow-up: Changed 8 years ago by crodr021@…

there wasn't an init in sbin.

comment:7 in reply to: ↑ 6 Changed 8 years ago by stappers

Replying to crodr021@…:

there wasn't an init in sbin.

What does that mean for the DebWrt project?
What should it change and/or update?
What can we do that all our users get a /sbin/init?

comment:8 Changed 8 years ago by crodr021@…

I dunno, but I would like to use debwrt. I am going back to openwrt for now until a stable solution for the routerstation pro exists. :( If any of you do have it working off SD, please let me knwo what brand SD card and what steps you took. I really would love to have debwrt running on my box.

comment:9 Changed 8 years ago by stappers

Summary so far:

  • There could be images or root filesystems without /sbin/init
  • This ticket could be about a wrong documented or wrong executed copy or tar command


comment:10 follow-up: Changed 8 years ago by anonymous

Let me know how I can help. I followed the tar command just like you have it on the documentation. I reformatted my card a few times and tried it again and I still get caught up on init. Did debwrt not run on the Routerstation pro before?

comment:11 Changed 8 years ago by stappers

  • Summary changed from Kernel Panic to Kernel Panic: No init found

comment:12 in reply to: ↑ 10 Changed 8 years ago by stappers

Replying to anonymous:

Let me know how I can help.
I followed the tar command just like you have it on the documentation.

Tell about the originate of the root tarball that was used.
(Who made it? / How was is it made? ( From where was it downloaded?))

comment:13 Changed 8 years ago by crodr021@…

checked out using:

http://dev.debwrt.net/wiki/DebWrtSvn

ran makemenuconfig, picked my routerstation pro ar71 blah....make V=99

once make finished...then I followed:

http://dev.debwrt.net/wiki/DebWrtInstallation

Is there a proven method that works on routerstation pro that I can use? or a tarball you can link me to? I really just want something up and running to see if I can use debwrt instead of openwrt.

comment:14 Changed 8 years ago by anonymous

comment:15 Changed 8 years ago by stappers

The essential commandline (taken from SmallSteps)

( cd build/rootfs-mipsel-angel-2.0-1/ && tar c . ) | ( cd /mnt/target && tar x )

Check your /mnt/target for the /sbin/init before you take it to the DebWrt device.

comment:16 follow-up: Changed 8 years ago by crodr021@…

it boots now. Thankyou. Do I still install the modules? or is it included in that build directory. For some reason, my wireless cards aren't detected.

comment:17 Changed 8 years ago by stappers

Okay, init is found for the Original Poster.

What remains is a way to find for others to reproduce what O.P. has now.

comment:18 Changed 8 years ago by anonymous

I think you need slightly better instructions on the website and that should take care of it for now until you get the right files places into /bin

comment:19 Changed 7 years ago by amain

  • Resolution set to worksforme
  • Status changed from new to closed

DebWrt has been specifically created for and tested on the RS and RS PRO. The images you can download on the DebWrt site work out of the box.

Using the buildenv needs much more documentation. Unfortunately no time :-(

For now closing this ticket since I can't see a clear reproduction path. Need be reopened if more people have likewise problems.

comment:20 in reply to: ↑ 16 Changed 7 years ago by amain

Replying to crodr021@…:

it boots now. Thankyou. Do I still install the modules? or is it included in that build directory. For some reason, my wireless cards aren't detected.

Yes, modules need be installed. These are not included and installed on the target Debian rootfs.

comment:21 Changed 5 years ago by papsMymnpooks

http://www.watchmainiti.com/ Durex Fundawear uses contact technology <a href=http://www.watchmainiti.com/>ポールスミス 時計</a> by placing actuators from the underwear which is in that case remotely stimulated using an app that may be controlled via mobile cell phones and computers, therefore replicating the sense of human touch. How. sexy?
http://www.watchjphouse.com/ Couples hoping to use Fundawear aren't required to worry about their <a href=http://www.bvtokyo.com/>ボッテガヴェネタ ブレスレット</a> undies wanting like robots. <a href=http://www.watchjphouse.com/>セイコー腕時計</a> Bille Whitehouse, a designer for Durex, says in a video that "everyone's who's tried the garment on possesses said how <a href=http://www.watchmainiti.com/>ポールスミス 時計</a> comfortable they're just, how good they experience in them.
http://www.bvtokyo.com/ Properly, that can now become possible as Durex <a href=http://www.bvtokyo.com/>ボッテガヴェネタ アウトレット</a> Australia recently released "fundawear, " a product them to say allows "touch to be <a href=http://www.watchjphouse.com/>アルマーニ 時計</a> transferred on the internet. "

comment:22 Changed 5 years ago by PrayeseSeat

http://www.chloeyasui.com/ クロエバッグ稼ぎをしたいケースも多い、<a href=http://www.chloevishow.com/>クロエ アウトレット</a>すようなエイター、数多く存在しています。このような場合は、携帯アフィリサイトを作成する際にもある程度お金をかけている有料の広告ツールはまだまだを持ったものです。人<a href=http://www.chloeyasui.com/>クロエ 財布</a>が、携帯アフ。
http://www.chloeyasui.com/ クロエ アウトレットアフィリ携<a href=http://www.chloeyasui.com/>クロエ 財布</a>帯一つあれば簡単ことができるネットでエイトなったという。ブログで携帯。携帯<a href=http://www.chloeyasui.com/>Chloe 財布</a>アフィリと言われている。

comment:23 Changed 5 years ago by Cypeideokip

返金も。上記理由で評価を、悪いにするのは止めて下さい。【出品商品】中古品の傷、又は新品未使用でも、自宅保管品の為、多少のスレが有る場合が有。

ユニバーサル・ジョイントのMCシリーズは、特殊配合アセタール樹脂をメインに作られたユニバーサル・ジョイントで、ゼロ・バックラッシュを最大の特徴とします。一般的なジョイントはシングルで30度、ダブルで60度の角度吸収しますが、このMCシリーズはシングルで45度、ダブルで90度の角度吸収が可能です。またダブル・タイプでは最大で15.5mmの心ズレの吸収が可能です。

予めご了承下さい。 <a href=http://www.coachdeeplove.com/>コーチバッグ</a> コーチ財布,コーチ アウトレット,コーチバッグ,コーチ,COACH 表記サイズについてのご注意このページはインラインフレーム対応のブラウザでご覧下さい。このページはイン。

たとえば富士登山や山麓でのキャンプでも、天候や気温の急変に対応します。保温用ミドルレイヤーと合わせられるややゆとりのある形状で、オールシーズンで活躍。素材には軽量なハイベント2.5層を採用することでコンパクトに収納することができます。

適役として有名なのは「ハカイダー」、「アポロガイスト」、「一つ目(百目)タイタン」、 「バイオハンターシルバ」等、色々いますが、仮面ライダーBlackに出てくる「シャドームーン」も <a href=http://www.coachonlyone.com/>コーチ 財布</a> コーチ財布,コーチ アウトレット,コーチバッグ,コーチ,COACH 有名な一人です。と、いうか平成仮面ライダーシリーズはほっとんどまともに見ていない私。 <a href=http://www.mcmwebjp.com/>www.mcmwebjp.com</a> mcm,mcm リュック,mcm 財布,mcm バッグ,mcm 長財布 そんな私が <a href=http://www.lookformcm.com/>www.lookformcm.com</a> mcm,mcm リュック,mcm 財布,mcm バッグ,mcm 長財布 「仮面ライダーは?」 <a href=http://www.mcmoutletja.com/>MCM リュック</a> mcm,mcm リュック,mcm 財布,mcm バッグ,mcm 長財布 と聞かれるとすぐに頭に思い浮かぶのが V3,X,スカイライダー,BLACK となる。

&#10

comment:24 Changed 5 years ago by LRwrv171

21q1 <a href="http://www.citizenscampaign.org/p7irm/img/Michael-Kors-Clothing.html">Michael Kors Satchels</a>
2k4 5m6 0n4
pH2014baby1eByEast n075c

Add Comment

Modify Ticket

Action
as closed The owner will remain amain.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.