Modify

Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#76 closed defect (invalid)

Missing --arch parameter when calling debootstrap

Reported by: k.szczesny@… Owned by: stappers
Priority: minor Milestone: milestone:
Component: debian/rootfs Version: 2.0
Severity: Keywords: XenoBuild
Cc:

Description

arch parameter is missing when calling debootstrap and thus throws following error:

# Due to various bugs in debootstrap in combination with fakechroot it is not
# possible to create a fakechroot here - and therefore we need to use chroot
# with sudo
#fakeroot fakechroot debootstrap
#--variant=fakechroot
sudo debootstrap --include="file,less,strace,sudo" \

squeeze \

/srv/krystian/debwrt/build/debian-ar71xx-generic_WNDR3700-squeeze \
"http://ftp.debian.org/debian"

E: Couldn't work out current architecture
make: * [debian/buildenv/prepare] Error 1

It is easily solvable by editing debian.mk file in debian/buildenv/

Attachments (0)

Change History (6)

comment:1 Changed 9 years ago by stappers

  • Owner changed from amain to stappers
  • Status changed from new to accepted

Please elaborate, because it works for me ...

comment:2 Changed 9 years ago by k.szczesny@…

Can't really tell you more than that. This is the message I get and his is how I solved it.
Have you got an up to date debootstrap? Maybe this is the case.

comment:3 Changed 9 years ago by k.szczesny@…

Or a matter of the system.
I'm running the whole thing on OpenSUSE 11.3 on an x86_64 machine.
I'm compiling for Netgear WNDR3700v2

comment:4 Changed 9 years ago by stappers

  • Keywords XenoBuild added
  • Priority changed from major to minor

For what it is worth: There is now the wiki page XenoBuild

comment:5 Changed 9 years ago by amain

  • Resolution set to invalid
  • Status changed from accepted to closed

On non Debian based systems I can imagine that debootrap ( installed from some RPM or wherever from ) is not able to detect which debian architecture it needs to setup a correct chroot ( the debwrt build env chroot ). I do need the auto detection though, because I can't assume that every body has an debian amd64 architecture.

e.g. works as designed. Though, if you have a nice patch which allows all situations, please attach and reopen. For now closing as invalid.

Using XenoBuild you can setup a debian chroot yourself and you won't walk into these type of problems.

comment:6 Changed 7 years ago by Elma

Are you willing to teach us how to prpleroy create a cross compiler in any given distro? So far the closest I have come is either use the arm-linux-gnueabi stuff that comes with Ubuntu 12.04 and a customized buildroot for the RPi.I'd love to learn how to build one the right way (as most manuals on the web about this have gotten me never any further that gcc stage 1) and then use it on my 16 core server. I've already done some kernel building on the same machine, and it builds a clean kernel in just a few minutes ON-TOPIC: Awesome post. I'll be trying this out in the next few days. I'd love to be able to run a virtual RPi in KVM

Add Comment

Modify Ticket

Action
as closed The owner will remain stappers.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.