Modify

Opened 9 years ago

Closed 9 years ago

#74 closed defect (fixed)

ath_debug_stat_tx : too many arguments to function 'ath_debug_stat_tx'

Reported by: E.D.Grootjans <e.d.grootjans@…> Owned by: amain
Priority: major Milestone: milestone:
Component: openwrt Version: 2.0
Severity: Keywords:
Cc:

Description

I have tryed to rebuild K+fs on usr/src/

First i did

cd /usr/src
svn co http://www.debwrt.net/repos/debwrt/trunk debwrt

then

cd /usr/src/debwrt
make menuconfig
LANG=C make

and i get the following output:

make -r world: build failed. Please re-run make with V=99 to see what's going on
make: *** [world] Error 1
make: Leaving directory `/usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-b43-trunk-default'
make: *** [openwrt/build] Error 2

then i did a make with V=99
This is what i entered:

sudo rm -rf /usr/src/debwrt/*
sudo rm -rf /usr/src/debwrt/.*
sudo rm -rf /usr/src/debwrt/.Trash-0

cd /usr/src
svn co http://www.debwrt.net/repos/debwrt/trunk debwrt

cd /usr/src/debwrt
make menuconfig
LANG=C make V=99

The following is the error
too many arguments to function 'ath_debug_stat_tx'

/usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-b43-trunk-default/build_dir/linux-brcm47xx/compat-wireless-2011-01-24/drivers/net/wireless/ath/ath9k/xmit.c: In function 'ath_tx_complete_buf':
/usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-b43-trunk-default/build_dir/linux-brcm47xx/compat-wireless-2011-01-24/drivers/net/wireless/ath/ath9k/xmit.c:1916: error: too many arguments to function 'ath_debug_stat_tx'
make[9]: *** [/usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-b43-trunk-default/build_dir/linux-brcm47xx/compat-wireless-2011-01-24/drivers/net/wireless/ath/ath9k/xmit.o] Error 1
make[8]: *** [/usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-b43-trunk-default/build_dir/linux-brcm47xx/compat-wireless-2011-01-24/drivers/net/wireless/ath/ath9k] Error 2
make[7]: *** [/usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-b43-trunk-default/build_dir/linux-brcm47xx/compat-wireless-2011-01-24/drivers/net/wireless/ath] Error 2
make[6]: *** [/usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-b43-trunk-default/build_dir/linux-brcm47xx/compat-wireless-2011-01-24/drivers/net/wireless] Error 2
make[5]: *** [_module_/usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-b43-trunk-default/build_dir/linux-brcm47xx/compat-wireless-2011-01-24] Error 2
make[5]: Leaving directory `/usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-b43-trunk-default/build_dir/linux-brcm47xx/linux-2.6.36.2'
make[4]: *** [modules] Error 2
make[4]: Leaving directory `/usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-b43-trunk-default/build_dir/linux-brcm47xx/compat-wireless-2011-01-24'
make[3]: *** [/usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-b43-trunk-default/build_dir/linux-brcm47xx/compat-wireless-2011-01-24/.built] Error 2
make[3]: Leaving directory `/usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-b43-trunk-default/package/mac80211'
make[2]: *** [package/mac80211/compile] Error 2
make[2]: Leaving directory `/usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-b43-trunk-default'
make[1]: *** [/usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-b43-trunk-default/staging_dir/target-mipsel_uClibc-0.9.31/stamp/.package_compile] Error 2
make[1]: Leaving directory `/usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-b43-trunk-default'
make: *** [world] Error 2
make: Leaving directory `/usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-b43-trunk-default'
make: *** [openwrt/build] Error 2
erik@britannica:/usr/src$ 

Attachments (0)

Change History (6)

comment:1 Changed 9 years ago by stappers

Reproducable.

make[4]: Entering directory `/usr/src/debwrt/build/openwrt-malta-le_Default-trunk-default/build_dir/linux-malta_le/compat-wireless-2011-01-24'
make -C /usr/src/debwrt/build/openwrt-malta-le_Default-trunk-default/build_dir/linux-malta_le/linux-2.6.36.2 M=/usr/src/debwrt/build/openwrt-malta-le_Default-trunk-default/build_dir/linux-malta_le/compat-wireless-2011-01-24 modules
make[5]: Entering directory `/usr/src/debwrt/build/openwrt-malta-le_Default-trunk-default/build_dir/linux-malta_le/linux-2.6.36.2'
  CC [M]  /usr/src/debwrt/build/openwrt-malta-le_Default-trunk-default/build_dir/linux-malta_le/compat-wireless-2011-01-24/drivers/net/wireless/ath/ath9k/xmit.o
/usr/src/debwrt/build/openwrt-malta-le_Default-trunk-default/build_dir/linux-malta_le/compat-wireless-2011-01-24/drivers/net/wireless/ath/ath9k/xmit.c: In function 'ath_tx_complete_buf':
/usr/src/debwrt/build/openwrt-malta-le_Default-trunk-default/build_dir/linux-malta_le/compat-wireless-2011-01-24/drivers/net/wireless/ath/ath9k/xmit.c:1916: error: too many arguments to function 'ath_debug_stat_tx'
make[9]: *** [/usr/src/debwrt/build/openwrt-malta-le_Default-trunk-default/build_dir/linux-malta_le/compat-wireless-2011-01-24/drivers/net/wireless/ath/ath9k/xmit.o] Error 1

That last line with line breaks

make[9]: *** [/usr/src/debwrt/build/openwrt-malta-le_Default-trunk-default
 /build_dir/linux-malta_le/compat-wireless-2011-01-24/drivers/net/wireless
 /ath/ath9k/xmit.o] Error 1

Non V=99 way to that Error 1:

 make[3] -C package/iw compile
 make[3] -C package/mac80211 compile
make -r world: build failed. Please re-run make with V=99 to see what's going on
make: *** [world] Error 1

comment:2 Changed 9 years ago by stappers

  • Component changed from debian to openwrt

My optimistic c.q. simplistic attempt to revert to a previous version of mac80211 fails in

Patch failed!  Please fix ./patches/310-pending_work.patch!
make[3]: *** [/usr/src/debwrt/build/openwrt-malta-le_Default-trunk-default/build_dir/linux-malta_le/compat-wireless-2011-01-19/.prepared_9fc10f57fa26853942d16518afbef755] Error 1
make[3]: Leaving directory `/usr/src/debwrt/build/openwrt-malta-le_Default-trunk-default/package/mac80211'
make[2]: *** [package/mac80211/compile] Error 2

comment:3 Changed 9 years ago by stappers

There is an update on the mac80211 package from Openwrt.
It makes sense to retry.

Additional information

cd /usr/src/debwrt
Board    : malta
Sub-Board: le_Default
cd /usr/src/debwrt/build/openwrt-malta-le_Default-trunk-default/package/mac80211
svn update
U    files/lib/wifi/mac80211.sh
U    patches/550-ath9k_optimize_memory_allocation.patch
U    patches/540-ath9k_fix_queue_debug.patch
Updated to revision 25234.
cd /usr/src/debwrt
make

your milage may vary

comment:4 Changed 9 years ago by E.D.Grootjans <e.d.grootjans@…>

Update seems to be OK:

erik@britannica:/media/DEBWRT_ROOT_/dev$ cd /usr/src
erik@britannica:/usr/src$ cd debwrt
erik@britannica:/usr/src/debwrt$ ls
Config.in  LICENSE   README  config  openwrt  tmp
INSTALL    Makefile  build   debian  rules
erik@britannica:/usr/src/debwrt$ make board
Board    : malta
Sub-Board: le_Default
erik@britannica:/usr/src/debwrt$ 
erik@britannica:/usr/src/debwrt$ cd build/openwrt-malta-le_Default-trunk-default/package/mac80211
erik@britannica:/usr/src/debwrt/build/openwrt-malta-le_Default-trunk-default/pack
age/mac80211$ svn update
U    files/lib/wifi/mac80211.sh
U    patches/550-ath9k_optimize_memory_allocation.patch
U    patches/540-ath9k_fix_queue_debug.patch
Updated to revision 25234.
erik@britannica:/usr/src/debwrt/build/openwrt-malta-le_Default-trunk-default/pack
age/mac80211$ cd /usr/src/debwrt
erik@britannica:/usr/src/debwrt$ make menuconfig #Checking if Malta was selected (and was)
config/mconf/mconf Config.in
#
# using defaults found in .config
#


Your configuration changes were NOT saved.

erik@britannica:/usr/src/debwrt$ make

Output in a few hours...

comment:5 Changed 9 years ago by E.D.Grootjans <e.d.grootjans@…>

Output:

.
.
Installing DebWrt package: swconfig
touch debian/rootfs/debwrt-packages
touch debian/rootfs/modules-install
sudo mkdir -p /usr/src/debwrt/build/rootfs-mipsel-angel-2.0-1/etc/apt
sudo bash -c "echo \"deb http://ftp.debian.org/debian squeeze main\" >/usr/src/debwrt/build/rootfs-mipsel-angel-2.0-1/etc/apt/sources.list"
touch debian/rootfs/post-setup
touch debian/rootfs
Make DebWrt completed

DEBWRTVERSION : angel - 2.0-1 - [ 29 January 2011 (r156) ]
TARGET_ARCH   : mipsel
BOARD         : malta
SUB_BOARD     : le_Default
LINUX_VERSION : 2.6.36.2 (default)
erik@britannica:/usr/src/debwrt$ 

looks good

Last edited 9 years ago by stappers (previous) (diff)

comment:6 Changed 9 years ago by stappers

  • Resolution set to fixed
  • Status changed from new to closed

The temporary build error is over.

Add Comment

Modify Ticket

Action
as closed The owner will remain amain.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.