Modify

Opened 9 years ago

Closed 9 years ago

#40 closed defect (fixed)

E: Package 'binutils-mipsel-linux-gnu' has no installation candidate

Reported by: Erik Grootjans Owned by: amain
Priority: major Milestone: milestone:
Component: debian/rootfs Version: 2.0
Severity: Keywords:
Cc:

Description

sudo chroot /home/erik/src/trunk/build/debian-brcm47xx-Broadcom-b43-squeeze bash -c "export LC_ALL=C; apt-get -y --force-yes install libc6-mipsel-cross libc6-dev-mipsel-cross binutils-mipsel-linux-gnu gcc-4.3-mipsel-linux-gnu g++-4.3-mipsel-linux-gnu linux-kernel-headers-mipsel-cross"
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'linux-libc-dev-mipsel-cross' instead of 'linux-kernel-headers-mipsel-cross'
Package binutils-mipsel-linux-gnu is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'binutils-mipsel-linux-gnu' has no installation candidate
make: * [debian/buildenv/emdebian-prepare] Fout 100

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by atlas

Same behavior when running "make debian/rootfs" !
It seems that the entire build is broken !

A quick workaround is to comment line 99 in:
--> trunk/debian/buildenv/debian.mk


#sudo chroot $(DEBIAN_BUILD_DIR) bash -c "export LC_ALL=C; apt-get -y --force-yes install libc6-$(TARGET_ARCH)-cross libc6-dev-$(TARGET_ARCH)-linux-gnu gcc-4.3-$(TARGET_ARCH)-linux-gnu g++-4.3-$(TARGET_ARCH)-linux-gnu linux-kernel-headers-$(TARGET_ARCH)-cross"


But then bad things happen:


mkdir -p /home/debwrt/build/trunk/bin/ar71xx-angel-2.0-1-default/debian
cp -rav /home/debwrt/build/trunk/build/debian-ar71xx-generic_UBNTRSPRO-lenny/usr/src/libnl/*.deb /home/debwrt/build/trunk/bin/ar71xx-angel-2.0-1-default/debian
cp: cannot stat `/home/debwrt/build/trunk/build/debian-ar71xx-generic_UBNTRSPRO-lenny/usr/src/libnl/*.deb': No such file or directory
make: * [debian/package/libnl/deliver] Error 1


Anyway, if you comment the folowing lines the build will pass.
--> trunk/debian/buildenv/package/debian.mk


# include $(TOPDIR)/debian/package/libnl/build.mk
# include $(TOPDIR)/debian/package/iw/build.mk

include $(TOPDIR)/debian/package/debwrt-kernel-headers/build.mk

# include $(TOPDIR)/debian/package/robocfg/build.mk
# include $(TOPDIR)/debian/package/nvram/build.mk
# include $(TOPDIR)/debian/package/hostapd/build.mk

include $(TOPDIR)/debian/package/shellinabox/build.mk
include $(TOPDIR)/debian/package/libpar2/build.mk
include $(TOPDIR)/debian/package/nzbget/build.mk

# include $(TOPDIR)/debian/package/libnl-tiny/build.mk
# include $(TOPDIR)/debian/package/swconfig/build.mk


The problem is that the commented sources will use for their build a downloaded toolchain
and not the toolchain that openwrt already compiled locally.

comment:2 Changed 9 years ago by amain

  • Resolution set to fixed
  • Status changed from new to closed

The emdebian repository was down / having problems. This should now be fixed.

Note: Indeed the OpenWrt toolchain is not used to compile the debian packages. For that the Emdebian tool chain is used.

Add Comment

Modify Ticket

Action
as closed The owner will remain amain.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.