Modify

Opened 8 years ago

Closed 7 years ago

#276 closed defect (duplicate)

Fail to patch current openwrt source for Brcm47xx with current DebWrt trunk.

Reported by: alpiroz@… Owned by:
Priority: minor Milestone: milestone:12.09
Component: openwrt Version: trunk
Severity: severity 4 Keywords: brcm47xx
Cc:

Description

Hello.

Seems like source code in trunk does not match current openwrt trunk source. At least for Brcm47xx.
This is true for 509 DebWRT revision.

Here what I get trying to execute make openwrt/menuconfig (some svn up output omitted)

...
Checked out revision 36140.
touch /usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-wl-trunk-default/.debwrt.checkout.stamp
touch openwrt/checkout
patch -d /usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-wl-trunk-default -p 0 -N \

< /usr/src/debwrt/openwrt/patches/001_disable_all_openwrt_packages

patching file include/toplevel.mk
Hunk #1 succeeded at 64 (offset 15 lines).
patching file ./scripts/debwrt_disables_packages.sed
patch -d /usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-wl-trunk-default -p 0 -N \

< /usr/src/debwrt/openwrt/patches/trunk/002_install_kernel_modules_and_merge_debwrt_config

patching file include/kernel-defaults.mk
Hunk #1 succeeded at 91 with fuzz 1 (offset 15 lines).
Hunk #2 succeeded at 110 (offset 17 lines).
patch -d /usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-wl-trunk-default -p 0 -N \

< /usr/src/debwrt/openwrt/patches/trunk/005_make_empty_rootfs

patching file include/image.mk
Hunk #1 succeeded at 90 (offset 3 lines).
#patch -d /usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-wl-trunk-default -p 1 -N < /usr/src/debwrt/openwrt/patches/trunk/006_reverse-changeset27849-changes.patch
#patch -d /usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-wl-trunk-default -p 0 -N \

< /usr/src/debwrt/openwrt/patches/003_set_kernel_version

patch -d /usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-wl-trunk-default -p 0 -N \

< /usr/src/debwrt/openwrt/patches/004_save_environment_variables

patching file Makefile
Hunk #1 FAILED at 90.
1 out of 1 hunk FAILED -- saving rejects to file Makefile.rej
make: * [openwrt/patch] Ошибка 1
azolotarenko@workbox:/usr/src/debwrt$

It seems like lines that should be patched are now moved below and they got some modifications.

Here what causes patch to fail
azolotarenko@workbox:/usr/src/debwrt$ cat /usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-wl-trunk-default/Makefile | sed -n '70,73 p'

for package in $(sort $(prereq-y) $(prereq-m)); do \

$(_SINGLE)$(NO_TRACE_MAKE) -s -r -C package/$$package prereq
ERROR=1; \

done; \
if [ -n "$$ERROR" ]; then \

azolotarenko@workbox:/usr/src/debwrt$

And here lines that I suppose should be changed

azolotarenko@workbox:/usr/src/debwrt$ cat /usr/src/debwrt/build/openwrt-brcm47xx-Broadcom-wl-trunk-default/Makefile | sed -n '89,93 p'
prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE

$(_SINGLE)$(SUBMAKE) -r package/index

# update all feeds, re-create index files, install symlinks
azolotarenko@workbox:/usr/src/debwrt$

Could you please verify if it is rigth?

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by stanley.pinchak@…

Here is my replacement openwrt/patches/004_save_environment_variables

It should work with openwrt versions > 33631

--- Makefile.org        2013-05-17 09:52:40.185502739 -0400
+++ Makefile    2013-05-17 09:57:36.435626047 -0400
@@ -86,8 +86,16 @@
                exit 1; \
        fi
 
+con:
+       echo "OPENWRT_BIN_DIR=$(BIN_DIR)" > $(TOPDIR)/.openwrt_env
+       echo "OPENWRT_PACKAGE_DIR=$(PACKAGE_DIR)" >> $(TOPDIR)/.openwrt_env
+       echo "OPENWRT_TMP_DIR=$(TMP_DIR)" >> $(TOPDIR)/.openwrt_env
+       #
+       # LINUX_VERSION is saved from include/kernel-defaults.mk
+       #
+
 prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
-world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
+world: con prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) con FORCE
        $(_SINGLE)$(SUBMAKE) -r package/index
 
 # update all feeds, re-create index files, install symlinks

comment:2 Changed 8 years ago by stanley.pinchak

This is a duplicate of #270 and there is an equivalent patch provided in that ticket as well as in the contrib branch in svn.

comment:3 Changed 7 years ago by amain

  • Milestone set to 12.09
  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.