Modify

Opened 7 years ago

Closed 6 years ago

#270 closed defect (fixed)

Build error on trunk: Deprecated patch

Reported by: kr105@… Owned by: amain
Priority: major Milestone: milestone:12.09
Component: buildsystem Version: 2.0
Severity: severity 4 Keywords:
Cc:

Description

I just downloaded the latest svn of debwrt and ran:

make menuconfig
(selected arch)
make openwrt/menuconfig
(it downloaded the openwrt svn, then applied some patches and failed on the last one)

It failed on the patch "004_save_environment_variables" saying that it was not able to patch the Makefile file.

I'm not aware of when the Openwrt's makefile changed but with current trunk it doesn't patch. I attached here the fixed/working "004_save_environment_variables" file that i just made and everything compiled fine.

Attachments (1)

004_save_environment_variables (828 bytes) - added by kr105@… 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by kr105@…

comment:1 Changed 7 years ago by amain

  • Owner set to amain
  • Status changed from new to accepted

Thanks for supplying the patch! We have a branch 'contrib' where I actually fixed the issue you mentioned. I should have backported it to trunk. If you encounter more trouble try contrib. I will try to merge back to trunk asap. Sorry for the inconvenience.

comment:2 Changed 6 years ago by amain

  • Milestone set to 12.09
  • Resolution set to fixed
  • Status changed from accepted to closed

Build issues have been fixed. Reopen if otherwise.

Add Comment

Modify Ticket

Action
as closed The owner will remain amain.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.