Modify

Opened 8 years ago

Closed 8 years ago

#255 closed defect (invalid)

Kernel panic - not syncing: No init found

Reported by: shinton@… Owned by: amain
Priority: blocker Milestone: milestone:
Component: other Version: 2.0
Severity: severity 4 Keywords:
Cc:

Description

On rt-n16 device using kernel 3.0.0 I get the following:

[ 16.700000] Failed to execute /sbin/init. Attempting defaults...
[ 16.704000] Kernel panic - not syncing: No init found. Try passing init= opt ion to kernel. See Linux Documentation/init.txt for guidance.

My complete bootlog obtained via serial can be found here: http://pastebin.ca/2110899

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by shinton@…

The file /sbin/init exists, this error is happening as I attempt to create a new plugin for the brcm4716. Could potentially be linked to ticket #167. If you wish to try and recreate this issue, here's the plugin I've been working with: http://dl.dropbox.com/u/29682150/brcm4716-clean.tar.gz

comment:2 Changed 8 years ago by shinton@…

I would like to add that no init related files are modified, check the plugin to see for yourself. This "brcm4716-clean" plugin I'm using essentially does 3 main things:

  1. copy brcm47xx target to newly created brcm4716 one, 2. patch using Georges patchset which is known to work with openwrt just fine and 3. apply fixes to let kernel version 3.0 work without and compilation error. Again I am using the fixes already created in openwrt to tackle this problem so there should be no issue here either.

All these factors lead me to believe that something is going wrong in debwrt side of things.

comment:3 Changed 8 years ago by shinton@…

Problem resolved, was caused by using incompatible patches with kernel 3.0.

comment:4 Changed 8 years ago by amain

  • Resolution set to invalid
  • Status changed from new to closed

Ok, closing ticket.

Add Comment

Modify Ticket

Action
as closed The owner will remain amain.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.