Modify

Opened 12 years ago

Closed 12 years ago

#22 closed defect (invalid)

Init not started after building first stage(debootstrap) rootfs

Reported by: Erik Grootjans Owned by: amain
Priority: major Milestone: milestone:
Component: debian/rootfs Version: 2.0
Severity: Keywords:
Cc:

Description

Ik heb met rev134 een kernel en een filesystem gebouwd.

Ik heb opgestart met het de nieuwe kernel en het oude filesysteem en dat werkte.
De nieuwe kernel heeft usb-serial support en dat werkt.

Ik heb het nieuwe fs op de usb stick gezet met tar (als root). En heb zonder de modules en met de modules proberen op te starten. In beide gevallen kwam ik niet in de fase van de init. Ik heb het gevoel dat er iets mist in het fs --- alleen weet ik niet wat. rechten staan volgens mij goed. En er is voldoende vrije ruimte op het fs. (Deze is 4 Gb groot).

Bij het opstarten met de oude fs, krijg ik het volgende:
Algorithmics/MIPS FPU Emulator v1.5
INIT: version 2.88 booting
diag: Detected 'Asus WL-500g DeLuxe?'
....
EXT3-fs (sda1): using internal journal
....

Bij het opstarten met het nieuwe fs krijg ik:
Algorithmics/MIPS FPU Emulator v1.5
EXT3-fs (sda1): using internal journal
diag: Detected 'Asus WL-500g DeLuxe?'
HIERNA NIKS MEER

Enig idee ?????

Attachments (2)

debian_rootfs_debian_mk.diff (943 bytes) - added by amain 12 years ago.
debwrt_first_stage_boot.log (15.8 KB) - added by amain 12 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 12 years ago by amain

  • Status changed from new to accepted
  • Summary changed from Geen Init bij booten to Init not started after building first stage(debootstrap) rootfs

Can you do als -la of / on the USB partition with the first stage debian rootfs? E.g. on the actual device you are using to boot. And a ls -l on /sbin/init, /bin/bash and bin/sh? And a file on /sbin/init and /bin/bash?

Changed 12 years ago by amain

Changed 12 years ago by amain

comment:2 Changed 12 years ago by amain

  • Resolution set to invalid
  • Status changed from accepted to closed

Checkout: r135
Target Profile: Broadcom BCM43xx WiFi? (b43, default))
Tested on: Asus WL-500G Premium v1

Temporary disabled installing DebWrt package because emdebian repo's are still down. See debian_rootfs_debian_mk.diff attachment.

Post installation debwrt init just boots fine. See debwrt_first_stage_boot.log

Closing ticket: can't reproduce problem

Add Comment

Modify Ticket

Action
as closed The owner will remain amain.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.