Modify

Opened 11 years ago

Closed 11 years ago

#189 closed defect (duplicate)

DebWRT fails to build when selecting debian wheezy

Reported by: shinton@… Owned by: amain
Priority: blocker Milestone: milestone:
Component: buildsystem Version: 2.0
Severity: severity 1 Keywords: blocker, debwrt-kernel-headers
Cc:

Description

During the debwrt-kernel-headers build phase the following error is encountered:

+ cd /usr/src/debwrt-kernel-headers/debwrt-kernel-headers-testing
+ dch -v testing-1 -m -t 'Automated packet generation'
+ dpkg-buildpackage -amipsel -rfakeroot -b
dpkg-buildpackage: source package debwrt-kernel-headers
dpkg-buildpackage: source version testing-1
dpkg-buildpackage: error: version number does not start with digit
+ xargs -r -t -i sudo dpkg-cross -a mipsel -i '{}'
+ find /usr/src/debwrt-kernel-headers -maxdepth 1 -name '*.deb'
touch debian/package/debwrt-kernel-headers/build
mkdir -p /home/stephen/debwrt/bin/brcm4716-testing-2.1-1-default/debian
cp -rav /home/stephen/debwrt/build/debian-brcm4716-None-wheezy/usr/src/debwrt-kernel-headers/*.deb /home/stephen/debwrt/bin/brcm4716-testing-2.1-1-default/debian
cp: cannot stat `/home/stephen/debwrt/build/debian-brcm4716-None-wheezy/usr/src/debwrt-kernel-headers/*.deb': No such file or directory
make: * [debian/package/debwrt-kernel-headers/deliver] Error 1
stephen@stephen-VirtualBox:~/debwrt$ make V=99
mkdir -p /home/stephen/debwrt/bin/brcm4716-testing-2.1-1-default/debian
cp -rav /home/stephen/debwrt/build/debian-brcm4716-None-wheezy/usr/src/debwrt-kernel-headers/*.deb /home/stephen/debwrt/bin/brcm4716-testing-2.1-1-default/debian
cp: cannot stat `/home/stephen/debwrt/build/debian-brcm4716-None-wheezy/usr/src/debwrt-kernel-headers/*.deb': No such file or directory
make:
* [debian/package/debwrt-kernel-headers/deliver] Error 1

Attachments (0)

Change History (2)

comment:1 Changed 11 years ago by shinton@…

Problem appears to be partially fixed by changing:

VERSION=echo $KERNEL_HEADERS_TAR_GZ | awk -F "-" '{print $6}'
-->
VERSION=echo $KERNEL_HEADERS_TAR_GZ | awk -F "-" '{print $7}'

In the file "debian/package/debwrt-kernel-headers/debwrt-kernel-headers.sh" However the following error still exists (though not a blocker):

+ cp -a /usr/src/debwrt-kernel-headers/config-kernel-2.1 /usr/src/debwrt-kernel-headers/debwrt-kernel-headers-2.1/.config
cp: cannot stat `/usr/src/debwrt-kernel-headers/config-kernel-2.1': No such file or directory

comment:2 Changed 11 years ago by amain

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket #174

Add Comment

Modify Ticket

Action
as closed The owner will remain amain.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.