Modify

Opened 8 years ago

Closed 8 years ago

#148 closed defect (worksforme)

DebWRT fails to build in r313 when selecting "Sid"

Reported by: davecc0132@… Owned by: amain
Priority: blocker Milestone: milestone:
Component: debian/rootfs Version: 2.0
Severity: severity 4 Keywords:
Cc:

Description

Attempting to build DebWRT for the rt-n16 it fails during debian second-stage install in qemu:

sudo bash -c "echo \"deb http://www.emdebian.org/debian stable main\" >> /home/davecc/debwrt/build/debian-brcm4716-None-sid/etc/apt/sources.list"
# Add lenny repo, just for apt-cross
sudo bash -c "echo \"deb http://ftp.debian.org/debian lenny main\" >> /home/davecc/debwrt/build/debian-brcm4716-None-sid/etc/apt/sources.list"
#sudo bash -c "echo -e \"Package: *\nPin: release a=lenny\nPin-Priority: 200\" > /home/davecc/debwrt/build/debian-brcm4716-None-sid/etc/apt/preferences"
sudo chroot /home/davecc/debwrt/build/debian-brcm4716-None-sid apt-get update
[...] (spam protection wouldn't let me include this many links)
Get:2 http://www.emdebian.org stable InRelease? [5030 B]
[...] (spam protection wouldn't let me include this many links)
Translation-en
Fetched 5031 B in 7s (702 B/s)
W: GPG error: http://www.emdebian.org stable InRelease?: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B5B7720097BB3B58
W: Failed to fetch http://ftp.debian.org/debian/dists/lenny/main/binary-i386/Packages 404 Not Found [IP: 130.89.149.226 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.
make: * [debian/buildenv/emdebian-prepare] Error 100

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by amain

Tried to reproduce. Used the rt-n16 plugin and selected sid on my AMD64 machine, but no problem. It just works. Your machine seems to be i386. The problem appears to be in the

deb  http://ftp.debian.org/debian lenny main

line in /etc/apt/soruces.list. Indeed the http://ftp.debian.org/debian/dists/lenny/main/binary-i386/Packages gives a 404. So it seems for i386 the source line is incorrect for i386(but I can't see what is wrong), or the mirror is incomplete? Try using another Debian mirror.

comment:2 Changed 8 years ago by anonymous

Problem was fixed by running:

make debian/rootfs/clean
make debian/package/clean
make debian/buildenv/clean

The error occurred while running:

make menuconfig
make V=99

comment:3 Changed 8 years ago by anonymous

Also is it normal to have to run make debian/rootfs multiple times due to failures such as hash sum msmatch and failed to download??

comment:4 Changed 8 years ago by amain

  • Resolution set to worksforme
  • Status changed from new to closed

No, that is not normal. It should work in one pass. Checksum missmatches etc indicate some network problem.

Closing ticket since it seems a local problem. If it persists, and you believe it is due to something in DebWrt, please reopen.

Add Comment

Modify Ticket

Action
as closed The owner will remain amain.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.