Modify

Opened 8 years ago

Closed 6 years ago

#128 closed defect (fixed)

b43 problems on Asus WL-500gp v2

Reported by: Frlo Owned by: amain
Priority: critical Milestone: milestone:unscheduled
Component: openwrt Version: 2.0
Severity: severity 2 Keywords: upstream problem
Cc:

Description

Any experience with AP mode on wl500gp v2?

On my device after start hostapd with minimal configuration after 20 sec, increased latency pings present. After cca minute device stops to respond.

Do anybody experience such kind of problem?

Thanks, Bye, Frlo

Attachments:

interface=wlan0
driver=nl80211
ssid=debwrt
channel=6

Request timed out.
Request timed out.
Reply from 192.168.128.14: bytes=32 time=3407ms TTL=64
Reply from 192.168.128.14: bytes=32 time=1ms TTL=64
Request timed out.
Reply from 192.168.128.14: bytes=32 time=2489ms TTL=64
Reply from 192.168.128.14: bytes=32 time=4ms TTL=64
Reply from 192.168.128.14: bytes=32 time=1ms TTL=64
Reply from 192.168.128.14: bytes=32 time=2996ms TTL=64
Reply from 192.168.128.14: bytes=32 time=1ms TTL=64
Reply from 192.168.128.14: bytes=32 time=1ms TTL=64
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Reply from 192.168.128.14: bytes=32 time=3ms TTL=64
Reply from 192.168.128.14: bytes=32 time=1ms TTL=64
Reply from 192.168.128.14: bytes=32 time=1ms TTL=64
Request timed out.
Reply from 192.168.128.14: bytes=32 time=1870ms TTL=64
Reply from 192.168.128.14: bytes=32 time=1ms TTL=64
Reply from 192.168.128.14: bytes=32 time=1ms TTL=64
Reply from 192.168.128.14: bytes=32 time=1ms TTL=64
Reply from 192.168.128.14: bytes=32 time=1996ms TTL=64
Reply from 192.168.128.14: bytes=32 time=1ms TTL=64
Reply from 192.168.128.14: bytes=32 time=1ms TTL=64
Reply from 192.168.128.14: bytes=32 time=2ms TTL=64
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Reply from 192.168.128.14: bytes=32 time=3ms TTL=64
Reply from 192.168.128.14: bytes=32 time=1ms TTL=64
Reply from 192.168.128.14: bytes=32 time=1ms TTL=64
Reply from 192.168.128.14: bytes=32 time=2356ms TTL=64
Reply from 192.168.128.14: bytes=32 time=9ms TTL=64
Reply from 192.168.128.14: bytes=32 time=123ms TTL=64
Reply from 192.168.128.14: bytes=32 time=11ms TTL=64
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
...

top - 21:30:10 up 2:36, 2 users, load average: 0.31, 0.10, 0.02
Tasks: 37 total, 3 running, 34 sleeping, 0 stopped, 0 zombie
Cpu(s): 24.7%us, 59.9%sy, 0.0%ni, 0.0%id, 0.0%wa, 15.1%hi, 0.3%si, 0.0%st
Mem: 29096k total, 26572k used, 2524k free, 1932k buffers
Swap: 136516k total, 0k used, 136516k free, 12776k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
256 root 16 -4 3048 860 556 R 58.8 3.0 0:04.84 udevd

4 root 20 0 0 0 0 R 40.1 0.0 0:01.45 events/0

1228 root 20 0 3272 1244 1044 R 2.1 4.3 0:00.33 top
1173 root 20 0 10740 2936 2460 S 0.3 10.1 0:03.33 sshd

root@debwrt:/etc/hostapd# hostapd -ddd /etc/hostapd/hostapd.minimal
Configuration file: /etc/hostapd/hostapd.minimal
netlink: Operstate: linkmode=1, operstate=5
nl80211: Add own interface ifindex 3
nl80211: New interface mon.wlan0 created: ifindex=7
nl80211: Add own interface ifindex 7
BSS count 1, BSSID mask 00:00:00:00:00:00 (0 bits)
nl80211: Added 802.11b mode based on 802.11g information
Allowed channel: mode=1 chan=1 freq=2412 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=2 freq=2417 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=3 freq=2422 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=4 freq=2427 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=5 freq=2432 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=6 freq=2437 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=7 freq=2442 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=8 freq=2447 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=9 freq=2452 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=10 freq=2457 MHz max_tx_power=20 dBm
Allowed channel: mode=1 chan=11 freq=2462 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=1 freq=2412 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=2 freq=2417 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=3 freq=2422 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=4 freq=2427 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=5 freq=2432 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=6 freq=2437 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=7 freq=2442 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=8 freq=2447 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=9 freq=2452 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=10 freq=2457 MHz max_tx_power=20 dBm
Allowed channel: mode=0 chan=11 freq=2462 MHz max_tx_power=20 dBm
Completing interface initialization
Mode: IEEE 802.11b Channel: 6 Frequency: 2437 MHz
RATE[0] rate=10 flags=0x1
RATE[1] rate=20 flags=0x1
RATE[2] rate=55 flags=0x0
RATE[3] rate=110 flags=0x0
Flushing old station entries
Deauthenticate all stations
wpa_driver_nl80211_set_key: ifindex=3 alg=0 addr=(nil) key_idx=0 set_tx=1 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=3 alg=0 addr=(nil) key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=3 alg=0 addr=(nil) key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=3 alg=0 addr=(nil) key_idx=3 set_tx=0 seq_len=0 key_len=0
Using interface wlan0 with hwaddr 48:5b:39:e7:d5:c9 and ssid 'debwrt'
nl80211: Set beacon (beacon_set=0)
wlan0: Setup of interface done.
RTM_NEWLINK: operstate=0 ifi_flags=0x1002 ()
nl80211: Interface down
Unknown event 29
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Unknown event 5
RTM_NEWLINK: operstate=0 ifi_flags=0x1002 ()
RTM_NEWLINK, IFLA_IFNAME: Interface 'mon.wlan0' added
Unknown event 5
RTM_NEWLINK: operstate=0 ifi_flags=0x11043 ([UP][RUNNING][LOWER_UP])
nl80211: Interface up
Unknown event 28
RTM_NEWLINK, IFLA_IFNAME: Interface 'mon.wlan0' added
Unknown event 5
RTM_NEWLINK: operstate=0 ifi_flags=0x11003 ([UP][LOWER_UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Unknown event 5
RTM_NEWLINK: operstate=0 ifi_flags=0x11003 ([UP][LOWER_UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
Unknown event 5
unknown vendor specific information element ignored (vendor OUI 00:10:18 len=9)
STA 00:26:5e:25:da:0f sent probe request for broadcast SSID
mgmt::proberesp cb
unknown vendor specific information element ignored (vendor OUI 00:10:18 len=9)
STA 00:26:5e:25:da:0f sent probe request for broadcast SSID
mgmt::proberesp cb
STA 00:16:ce:59:10:b5 sent probe request for broadcast SSID
mgmt::proberesp cb
STA 00:16:ce:59:10:b5 sent probe request for broadcast SSID
mgmt::proberesp cb
STA 00:1c:bf:12:50:14 sent probe request for broadcast SSID
mgmt::proberesp cb
unknown vendor specific information element ignored (vendor OUI 00:10:18 len=9)
unknown vendor specific information element ignored (vendor OUI 00:10:18 len=9)
unknown vendor specific information element ignored (vendor OUI 00:10:18 len=9)
unknown vendor specific information element ignored (vendor OUI 00:10:18 len=6)
STA 00:14:a4:55:23:2f sent probe request for broadcast SSID
mgmt::proberesp cb
STA 00:1c:bf:0e:19:ad sent probe request for broadcast SSID
mgmt::proberesp cb
STA 00:1d:d9:57:72:43 sent probe request for broadcast SSID
mgmt::proberesp cb
STA 00:1d:d9:57:72:43 sent probe request for broadcast SSID
mgmt::proberesp cb
STA 00:1d:d9:57:72:43 sent probe request for broadcast SSID
mgmt::proberesp cb
unknown vendor specific information element ignored (vendor OUI 00:10:18 len=6)
STA 00:14:a5:1e:95:c6 sent probe request for broadcast SSID
mgmt::proberesp cb
unknown vendor specific information element ignored (vendor OUI 00:10:18 len=9)
unknown vendor specific information element ignored (vendor OUI 00:10:18 len=9)
unknown vendor specific information element ignored (vendor OUI 00:03:47 len=7)
unknown vendor specific information element ignored (vendor OUI 00:03:47 len=7)
unknown vendor specific information element ignored (vendor OUI 00:03:47 len=7)
STA 00:13:e8:82:59:6f sent probe request for broadcast SSID
mgmt::proberesp cb
unknown vendor specific information element ignored (vendor OUI 00:10:18 len=9)
unknown vendor specific information element ignored (vendor OUI 00:10:18 len=9)

Attachments (0)

Change History (7)

comment:1 Changed 8 years ago by amain

  • Component changed from other to openwrt
  • Keywords upstram problem added
  • Status changed from new to accepted

There are still problems with the b43 driver. See b43. See also the following ticket on OpenWrt 7552.

Leaving ticket until OpenWrt/b43 guys come up with a fix.

comment:2 Changed 8 years ago by amain

  • Keywords upstream added; upstram removed

comment:3 Changed 8 years ago by amain

  • Summary changed from Problems on Asus WL-500gp v2 to b43 problems on Asus WL-500gp v2

comment:4 Changed 8 years ago by amain

Workaround: use proprietary wl driver with the nas AP daemon.

comment:5 Changed 7 years ago by amain

Lot of people experiencing same issue. See OpenWrt ticket. Apparently the problem was posted on Linux Wireless mailing list. But no real answers yet. Keeping ticket open.

comment:6 Changed 6 years ago by amain

  • Milestone set to unscheduled
  • Severity changed from severity 4 to severity 2

comment:7 Changed 6 years ago by amain

  • Resolution set to fixed
  • Status changed from accepted to closed

Upstream ticket was recently closed. Finally after many years a fix has been found and is available in OpenWrt. However, note that Hauke is pointing out that some change around DMA handling may be still needed. This seems to require however a rewrite of a part of the DMA handling code.

For now closing.

Add Comment

Modify Ticket

Action
as closed The owner will remain amain.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.