Modify

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#123 closed defect (fixed)

first boot telnetd doesn't ask for password

Reported by: stappers Owned by: stappers
Priority: major Milestone: milestone:
Component: buildsystem Version: 2.0
Severity: severity 4 Keywords:
Cc:

Description

Hello,

Where I previously did use ssh succesfull, is sshd not running in my latest build.
For the first time I did use telnet
and this is what I get

$ telnet awr
Trying 192.168.1.1...
Connected to awr.
Escape character is '^]'.
Debian GNU/Linux 6.0
debwrt login: root

Login incorrect
debwrt login: root

Login incorrect
debwrt login: root

Login incorrect

Note that there is no password question.

My question:

  • Who else is seeing this behaviour?

Attachments (0)

Change History (9)

comment:1 in reply to: ↑ description Changed 9 years ago by stappers

  • Priority changed from trivial to minor

Replying to stappers:

...

Note that there is no password question.

My question:

  • Who else is seeing this behaviour?

I do on my routerboard450G

comment:2 Changed 9 years ago by stappers

  • Owner changed from amain to stappers
  • Priority changed from minor to major
  • Status changed from new to accepted

With another user as root, I'm prompted for a password.

comment:3 Changed 9 years ago by stappers

Commit r243 introduces user debwrt for NON root log in over telnet.

comment:4 Changed 8 years ago by amain

stappers, I see commit 243. I was aware of some problems with telnet during login when using inital second stage setup. For root logins the root user must be added to /etc/securetty or some similar file. And maybe some other stuff. Probably something has changed on the Debian side. I don't want to add the debwrt user account to the rootfs by default. I want to keep it as clean as possible. Only a root user. A normal user still will not allow to complete the second stage install since that needs to be done as root and sudo is and will not be setup on forehand. Would you mind reverting the patch?

comment:5 Changed 8 years ago by stappers

Reverting r243 results in not being able to login when sshd is not available on a device without serial port. (That was the reason what did triggering this ticket)

Reverting r243 does mean that is useless to start telnetd at rcS.firstboot.

And to answer the question: Yes, I do mind to revert the patch also known as commit r243.

About finish second stage as root:
There a two possible ways to become root after an user login

  • su -
  • sudo su -

comment:6 Changed 8 years ago by stappers

  • Resolution set to fixed
  • Status changed from accepted to closed

now covered in FrequentlyAskedQuestions

comment:7 Changed 8 years ago by amain

  • Component changed from debian to buildsystem
  • Resolution fixed deleted
  • Status changed from closed to reopened

Please revert r243 and restore/fix the original functionality for second stage install rcS:

  • telnetd should run
  • sshd should run ( also to allow scp )
  • root login should be allowed by both telnetd and sshd

after second stage install:

  • telnetd will NOT run ( e.g. (x)inetd not started and not configured )
  • sshd will run ( user should recreate RSA?DSA keys )
  • root user remains
  • no other users dangling around

there is no need to change anything that works as designed

comment:8 Changed 8 years ago by stappers

  • Resolution set to fixed
  • Severity set to severity 4
  • Status changed from reopened to closed

Stretched /etc/securetty and reverted r243

comment:9 Changed 8 years ago by amain

Tested it on RS Pro/MIPS rootfs from latest trunk and works perfect! Thanks!

Add Comment

Modify Ticket

Action
as closed The owner will remain stappers.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.