Modify

Opened 9 years ago

Closed 8 years ago

#122 closed defect (invalid)

Invalid module format

Reported by: stappers Owned by: amain
Priority: major Milestone: milestone:
Component: buildsystem Version: 2.0
Severity: severity 4 Keywords:
Cc:

Description

Doing

modprobe usbserial

got me

FATAL: Error inserting usbserial \
(/lib/modules/2.6.37.6/usbserial.ko): Invalid module format

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by stappers

  • Component changed from openwrt to buildsystem

From a websearch:

Could the kernel you are using have been compiled with a different compiler
then the modules you are trying to modprobe?


Oh great, I could have thought of that myself, Frank. ;-)

I compiled the kernel with gcc-3.3, but I think I might have compiled
the module with the current gcc-4.0.

I don't know how that applies for debwrt.

comment:2 Changed 8 years ago by stappers

  • Resolution set to invalid
  • Severity set to severity 4
  • Status changed from new to closed

Can't reproduce ... closing as 'invalid'

Add Comment

Modify Ticket

Action
as closed The owner will remain amain.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.