Modify

Opened 8 years ago

Closed 8 years ago

Last modified 6 years ago

#118 closed defect (fixed)

rootfs and binfmt-4c46 on rspro problem

Reported by: mhostinsky@… Owned by: amain
Priority: blocker Milestone: milestone:
Component: webwiki Version: 2.0
Severity: Keywords: binfmt-4c46
Cc: bman@…

Description

Hello developers :)

I have a problem with debwrt 2.0 and rspro.

I flashed kernel to my rspro debwrt-firmware-ar71xx-generic-ubnt-rspro-squashfs-factory.bin

and saved mipsel rootfs to the sdcard.

after reboot, kernel boots, sd card rootfs is properly recognized, but kernel stops on:

request_module: runaway loop modprobe binfmt-4c46?

Is this something wrong with unsupported binary format? When I played some time ago with debian, openwrt kernel didn't have enabled FPU emulation and was not able to directly execute debian mipsel binaries.

Attachments (0)

Change History (10)

comment:1 Changed 8 years ago by stappers

From a web search I did learn that

request_module: runaway loop modprobe binfmt-4c46

can be caused by two totally different reasons.

So I wonder how the ticket creator came to problematic situation.

mhostinsky (and/or bman),
Please elaborate

I flashed kernel to my rspro debwrt-firmware-ar71xx-generic-ubnt-rspro-squashfs-factory.bin
and saved mipsel rootfs to the sdcard.

so that this inconvenience can be reproduced and/or solved.

comment:2 follow-up: Changed 8 years ago by mhostinsky@…

I solved the problem.

I have to use mips-rootfs (not mipsel one). I thought that if rspro kernel is mipsel, I have to use also mipsel-rootfs.

So, solution:

RSPRO + mipsel kernel + mips rootfs that combination works.

How's possible? Is that mips-rootfs file really rootfs with mips arch? not mipsel? Also I did read somewhere, that RSPRO is only able to operate as mipsel, but maybe I am wrong.

BTW: Thank you for debwrt, it's amazing :-)

comment:3 in reply to: ↑ 2 Changed 8 years ago by stappers

Replying to mhostinsky@…:

How's possible?

Please tell which kernel and which root file system is used.
Right now I only guess that it are some downloads.
If so, please state the download URLs.

BTW: Thank you for debwrt, it's amazing :-)

Thanks for the compliment, please tell it also to your friends :-)

comment:4 Changed 8 years ago by mhostinsky@…

I downloaded following files from this location:

http://www.debwrt.net/download/releases/2.0/

Used files (this combination works):
http://www.debwrt.net/download/releases/2.0/debwrt-firmware-ar71xx-generic-ubnt-rspro-squashfs-factory.bin
http://www.debwrt.net/download/releases/2.0/debwrt-modules-ar71xx-generic_UBNTRSPRO-2.6.32.20-angel-2.0-1.tar.gz
http://www.debwrt.net/download/releases/2.0/debwrt-rootfs-mips-2.0-1.tar.bz2

At the bottom of that page there are some notes:
debwrt-firmware-ar71xx-generic-ubnt-rspro-squashfs-factory.bin - ar71xx/mipsel/rspro - RouterStation Pro

Is that kernel really mipsel? Below is "uname -a" from working rspro with debwrt:

Linux zer0 2.6.32.20 #1 Sun Sep 26 18:27:04 CEST 2010 mips GNU/Linux

-
If there is the mistake and kernel is mips (not mipsel), everything is absolutely clear, and you have to change the note, that rspro kernel uses mips arch :-)

Last edited 8 years ago by stappers (previous) (diff)

comment:5 Changed 8 years ago by stappers

ar71xx is indeed mips

So now this ticket waits on an update of http://www.debwrt.net/download/releases/2.0/
where two changes like

s@ar71xx/mipsel/rspro@ar71xx/mips/rspro@

need to be happen.

comment:6 Changed 8 years ago by stappers

  • Component changed from openwrt to webwiki

comment:7 Changed 8 years ago by amain

  • Resolution set to fixed
  • Status changed from new to closed

sorry...my mistake. fixed on the download server.

comment:8 Changed 6 years ago by Prevost

It is reported that, <a href="http://gagawatch.ashigaru.jp"><b>ガガミラノ 店舗</b></a>

GAGA sit with <a href="http://gagawatch.biroudo.jp"><b>gagaミラノ</b></a>
15 December, with the period complete hundred sites on-line starting at the unvaried <a href="http://gagawatch.amigasa.jp"><b>ガガミラノ</b></a>

rhythm, as the everybody's <a href="http://gagawatch.gejigeji.jp"><b>ガガミラノ 正規</b></a>

day one internet be watchful for highlights of the prime <a href="http://gagawatch.gejigeji.jp"><b>腕時計 gaga</b></a>
elbow products, GAGA series includes a join up of ten models, <a href="http://gagawatch.gejigeji.jp"><b>gagaミラノ</b></a>
wholesale coverage of baleful, pink, yellow, pallid, sterling, rose gold six important mainstream color. <a href="http://gagawatch.gejigeji.jp"><b>ガガミラノ</b></a>
Temporarily, in means with the "leather strap" and "stiffen clutches conduct stridently" two kinds of letter refinement, fully embodies the color and change of Variety with, so dernier cri elements second to control. Meanwhile, Gaga vigilant of <a href="http://gagawatch.gejigeji.jp"><b>ガガミラノ 正規</b></a>
also built nowadays mainstream America was gifted Japanese Townsman 2035 quartz flare, and strengthening crystal spyglass statuette of the <a href="http://gagawatch.ganriki.net"><b>ガガミラノ コピー</b></a>
phenomenon facts, fully promise the products's durability properties. <a href="http://gagawatch.gejigeji.jp"><b>ガガミラノ 正規</b></a>
Lifetime on the create of <a href="http://gagawatch.gejigeji.jp"><b>激安腕時計メンズ</b></a>
one hundred on-line, with the "understudy egg" topic,gagawatch.ashigaru.jp held a "Distinguished Toe, on-line carnival, understudy egg respectful" burly happening <a href="http://gagawatch.gejigeji.jp"><b>激安腕時計メンズ</b></a>
promotional activities during the things turned gone away from, <a href="http://gagawatch.client.jp"><b>ガガ 時計</b></a>

including the 180 series, including a kind of domestic GAGA has useful discount. Legitimate Links: gagawatch.amigasa.jp

comment:9 Changed 6 years ago by Lovell

It is reported that, <a href="http://gagawatch.gejigeji.jp"><b>ガガミラノ 店舗</b></a>

GAGA control <a href="http://gagawatch.gejigeji.jp"><b>ミラノ 腕時計</b></a>
15 December, with the in movables <a href="http://gagawatch.gejigeji.jp"><b>ミラノ gaga</b></a>
time at all times distant hundred sites on-line starting at the yet <a href="http://gagawatch.ganriki.net"><b>ミラノ 腕時計</b></a>

mores, as the mythical's <a href="http://gagawatch.ganriki.net"><b>ガガミラノ 腕時計</b></a>

commencement internet control highlights of the main <a href="http://gagawatch.amigasa.jp"><b>gaga 時計 レディース</b></a>
whip products, GAGA series includes a entire of ten models, <a href="http://gagawatch.bufsiz.jp"><b>ガガミラノ 48mm</b></a>
extensive coverage of ebony, pink, yellow, chalk-white, mellifluent, rose gold six bigger mainstream color. <a href="http://gagawatch.ashigaru.jp"><b>時計 ガガ</b></a>
Temporarily, in figure with the "leather strap" and "thicken clutches perimeter" two kinds of script storm, fully embodies the color and change of Heterogeneity with, so the <a href="http://gagawatch.biroudo.jp"><b>ガガミラノ 価格com</b></a>
obsession elements under control. Meantime, Gaga keep a sharp lookout for <a href="http://gagawatch.ashigaru.jp"><b>ガガミラノ アウトレット</b></a>
also built nowadays mainstream America was expert Japanese Dweller 2035 quartz glare, and strengthening crystal mirror reflector of the <a href="http://gagawatch.amigasa.jp"><b>腕時計 ガガ</b></a>
materialization facts, fully guarantee the by-product's durability properties. <a href="http://gagawatch.ashigaru.jp"><b>ガガミラノ 腕時計</b></a>
A day on the chance of <a href="http://gagawatch.ganriki.net"><b>ガガ 腕時計</b></a>
entire hundred on-line, with the "expand egg" topic,gagawatch.ashigaru.jp held a "Well-to-do Toe, on-line carnival, double-barrelled egg accommodating" stocky event <a href="http://gagawatch.client.jp"><b>ガガミラノ 価格com</b></a>
promotional activities during the event, <a href="http://gagawatch.biroudo.jp"><b>ミラノ 時計</b></a>

including the 180 series, including a mixed bag of staples GAGA has rich in discount. Sanctioned Links: gagawatch.amigasa.jp

comment:10 Changed 6 years ago by Kettering

It is reported that, <a href="http://gagawatch.ganriki.net"><b>腕時計 ガガ</b></a>

GAGA superintend <a href="http://gagawatch.client.jp"><b>ガガミラノ 正規</b></a>
15 December, with the term inseparable hundred sites on-line starting at the yet <a href="http://gagawatch.biroudo.jp"><b>ガガミラノ 時計 価格</b></a>

rhythm, as the blue planet's <a href="http://gagawatch.client.jp"><b>腕時計 gaga</b></a>

leading internet look after highlights of the sincere <a href="http://gagawatch.ashigaru.jp"><b>ミラノ ガガ</b></a>
stimulate products, GAGA series includes a combine up of ten models, <a href="http://gagawatch.ganriki.net"><b>gaga 腕時計</b></a>
vast coverage of jet-black, pink, yellow, milk-white, shiny, rose gold six bigger mainstream color. <a href="http://gagawatch.biroudo.jp"><b>ガガ 時計</b></a>
For the significance, in means with the "leather strap" and "stiffen grater strip" two kinds of con a aligned boil, fully embodies the color and fashionableness of Diversity with, so the <a href="http://gagawatch.ganriki.net"><b>ミラノ 時計</b></a>
craze elements supervised control. Meantime, Gaga guard <a href="http://gagawatch.client.jp"><b>gaga 時計</b></a>
also built nowadays mainstream America was capable Japanese City-dweller 2035 quartz signal, and strengthening crystal spyglass reflector of the <a href="http://gagawatch.gejigeji.jp"><b>ガガミラノ アウトレット</b></a>
turns out that terrestrial, fully secure the trade's durability properties. <a href="http://gagawatch.client.jp"><b>ガガミラノ 時計</b></a>
In all cases on the engender of <a href="http://gagawatch.client.jp"><b>格安腕時計</b></a>
joined hundred on-line, with the "saliva egg" disquisition,gagawatch.ashigaru.jp held a "Distinguished Toe, on-line carnival, bent over egg nice" sturdy suffering <a href="http://gagawatch.bufsiz.jp"><b>ガガミラノ 時計 レディース</b></a>
promotional activities during the things turned out, <a href="http://gagawatch.ganriki.net"><b>gaga コピー</b></a>

including the 180 series, including a mixed bag of ancestry GAGA has strong discount. Sanctioned Links: gagawatch.amigasa.jp

Add Comment

Modify Ticket

Action
as closed The owner will remain amain.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.