Modify

Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#116 closed defect (fixed)

Build Error 1 and Error 2 with random.o -- hostapd?

Reported by: e.d.grootjans@… Owned by: amain
Priority: major Milestone: milestone:
Component: debian/packages Version: 2.0
Severity: severity 4 Keywords:
Cc:

Description

I did a clean build (first delete everything in the directory debwrt) with rev196
and got the following output:

CC  ../src/crypto/rc4.c
../src/crypto/random.c: In function 'random_pool_ready':
../src/crypto/random.c:198: error: storage size of 'st' isn't known
../src/crypto/random.c:202: warning: implicit declaration of function 'stat'
../src/crypto/random.c:198: warning: unused variable 'st'
../src/crypto/random.c: In function 'random_mark_pool_ready':
../src/crypto/random.c:275: error: 'O_NOFOLLOW' undeclared (first use in this function)
../src/crypto/random.c:275: error: (Each undeclared identifier is reported only once
../src/crypto/random.c:275: error: for each function it appears in.)
make[1]: *** [../src/crypto/random.o] Error 1
make[1]: Leaving directory `/usr/src/hostapd/hostapd-1.0/src/hostapd'
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
+ xargs -r -t -i sudo dpkg-cross -a mipsel -i '{}'
+ find /usr/src/hostapd -maxdepth 1 -name '*.deb'
touch debian/package/hostapd/build
mkdir -p /usr/src/debwrt/bin/brcm47xx-angel-2.0-1-default/debian
cp -rav /usr/src/debwrt/build/debian-brcm47xx-Broadcom-b43-squeeze/usr/src/hostapd/*.deb /usr/src/debwrt/bin/brcm47xx-angel-2.0-1-default/debian
cp: cannot stat `/usr/src/debwrt/build/debian-brcm47xx-Broadcom-b43-squeeze/usr/src/hostapd/*.deb': No such file or directory
make: *** [debian/package/hostapd/deliver] Error 1
erik@britannica:/usr/src$ 

Attachments (0)

Change History (14)

comment:1 Changed 7 years ago by stappers

Reproducable. At least by me.

I think this is since hostapd version 20110402

comment:2 follow-up: Changed 7 years ago by simeon.miteff@…

Also reproduced here. I don't need hostapd, so I commented it out in:

debian/package/debian.mk

...and now the build completes.

Still have to flash it an see what happens :-)

comment:3 follow-up: Changed 7 years ago by e.d.grootjans@…

If i do the build --- hostapd is not yet commended out
Get still the same error.

../src/crypto/random.c:275: error: for each function it appears in.)
make[1]: *** [../src/crypto/random.o] Error 1
make[1]: Leaving directory `/usr/src/hostapd/hostapd-1.0/src/hostapd'
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

comment:4 in reply to: ↑ 2 Changed 7 years ago by stappers

Replying to simeon.miteff@…:

Also reproduced here. I don't need hostapd, so I commented it out in:

debian/package/debian.mk

...and now the build completes.

That "work a round" in unified patch format:

--- a/debian/package/debian.mk
+++ b/debian/package/debian.mk
@@ -23,7 +23,7 @@ include $(TOPDIR)/debian/package/iw/build.mk
 include $(TOPDIR)/debian/package/debwrt-kernel-headers/build.mk
 include $(TOPDIR)/debian/package/robocfg/build.mk
 include $(TOPDIR)/debian/package/nvram/build.mk
-include $(TOPDIR)/debian/package/hostapd/build.mk
+# include $(TOPDIR)/debian/package/hostapd/build.mk
 # include $(TOPDIR)/debian/package/shellinabox/build.mk
 # include $(TOPDIR)/debian/package/libpar2/build.mk
 # include $(TOPDIR)/debian/package/nzbget/build.mk

and as said, this is only helpfull if hostapd can be missed.

comment:5 in reply to: ↑ 3 Changed 7 years ago by stappers

Replying to e.d.grootjans@…:

If i do the build --- hostapd is not yet commended out
Get still the same error.

Since r205 is a quick check upon a new hostapd version possible.

$ make debian/package/hostapd/version
PKG_VERSION:=20110402

Other versions as 20110402 could be / should be tried.

comment:6 Changed 7 years ago by stappers

  • Priority changed from major to blocker

For what it is worth: I consider this FTBFS, fails to build from source, as a blocker.

Marking as such.

Last edited 7 years ago by stappers (previous) (diff)

comment:7 Changed 7 years ago by stappers

  • Component changed from buildsystem to packages
  • Priority changed from blocker to major

Since r217 is a clean compile of hostapd possible again.

Functionality of hostapd not tested.

(Yep, I still don't have debwrt running on hardware with WIFI)

comment:8 follow-up: Changed 7 years ago by amain

  • Resolution set to fixed
  • Status changed from new to closed

clean compile is possible again...assuming that it works again :-)

comment:9 in reply to: ↑ 8 Changed 7 years ago by stappers

  • Resolution fixed deleted
  • Severity set to severity 4
  • Status changed from closed to reopened

This reopening happened after seeing ticket #128

clean compile is possible again...assuming that it works again :-)

The only sure thing is the clean compile
and there is a rumour that assumption is the mother of all fuck-ups

Repeating from comment 7:

Functionality of hostapd not tested.
(Yep, I still don't have debwrt running on hardware with WIFI)

comment:10 Changed 7 years ago by amain

  • Resolution set to fixed
  • Status changed from reopened to closed

This error was about a compile error. Compile error has been fixed upstream. Ticket #128 has nothing to do with this ticket.

comment:11 Changed 7 years ago by stappers

  • Resolution fixed deleted
  • Status changed from closed to reopened

In r253 is the debwrt change de-activated.

comment:12 Changed 7 years ago by anonymous

In r261 I am still receiving this error, anyone else?

comment:13 Changed 7 years ago by amain

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in r263. Thanks for al the help!

comment:14 Changed 5 years ago by Lockhart

It is reported that, <a href="http://gagawatch.ganriki.net"><b>腕時計 gaga</b></a>

GAGA seat with <a href="http://gagawatch.gejigeji.jp"><b>ガガミラノ 正規</b></a>
15 December, with the generation solitary hundred sites on-line starting at the same <a href="http://gagawatch.ganriki.net"><b>ガガミラノ</b></a>

ever, as the everybody's <a href="http://gagawatch.ashigaru.jp"><b>ガガ ミラノ</b></a>

oldest internet control highlights of the cardinal <a href="http://gagawatch.bufsiz.jp"><b>ガガミラノ 時計 価格</b></a>
net products, GAGA series includes a unmoderated of ten models, <a href="http://gagawatch.amigasa.jp"><b>ガガミラノ 時計 レディース</b></a>
vast coverage of baleful, pink, yellow, sorry, silver, rose gold six bigger mainstream color. <a href="http://gagawatch.biroudo.jp"><b>gaga 時計</b></a>
In the meantime, in rule with the "leather strap" and "protect webbing perimeter" two kinds of politeness rage, fully embodies the color and invent of Heterogeneity with, so dernier cri elements junior to control. In the meantime, Gaga on one's guard for <a href="http://gagawatch.client.jp"><b>ミラノ 時計</b></a>
also built nowadays mainstream America was effectual Japanese Dweller 2035 quartz repositioning, and strengthening crystal opera-glasses replication of the <a href="http://gagawatch.amigasa.jp"><b>時計 ミラノ</b></a>
turns visible that laic, fully poise the consequence's durability properties. <a href="http://gagawatch.ganriki.net"><b>アウトレット ミラノ</b></a>
Nonetheless on the function of <a href="http://gagawatch.client.jp"><b>gagaミラノ</b></a>
one hundred on-line, with the "twofold egg" story,gagawatch.ashigaru.jp held a "Exalted Split, on-line carnival, strange as surplus egg deferential" philanthropic likelihood <a href="http://gagawatch.gejigeji.jp"><b>時計 ミラノ</b></a>
promotional activities during the things turned out, <a href="http://gagawatch.ashigaru.jp"><b>腕時計 gaga</b></a>

including the 180 series, including a kind of domestic GAGA has profuse discount. Official Links: gagawatch.amigasa.jp

Add Comment

Modify Ticket

Action
as closed The owner will remain amain.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.