Modify

Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#106 closed defect (worksforme)

Missing SVN: could not connect to server (https://svn.debwrt.net)

Reported by: stappers Owned by: amain
Priority: major Milestone: milestone:
Component: buildsystem Version: 2.0
Severity: Keywords:
Cc:

Description

$ svn update
svn: OPTIONS of 'https://svn.debwrt.net/debwrt/trunk': could not connect to server (https://svn.debwrt.net)

Attachments (0)

Change History (8)

comment:1 Changed 12 years ago by stappers

  • Resolution set to worksforme
  • Status changed from new to closed

Seems to work ...

stappers@inertia:/usr/src/debwrt
$ svn update
At revision 184.
stappers@inertia:/usr/src/debwrt
$ date
vr mrt 25 22:06:52 CET 2011
stappers@inertia:/usr/src/debwrt
$ svn update
At revision 184.
stappers@inertia:/usr/src/debwrt
$ 

comment:2 Changed 12 years ago by stappers

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Another intermission

stappers@inertia:/usr/src/debwrt
$ svn update
svn: OPTIONS of 'https://svn.debwrt.net/debwrt/trunk': could not connect to server (https://svn.debwrt.net)
stappers@inertia:/usr/src/debwrt
$ date
ma mrt 28 22:30:03 CEST 2011
stappers@inertia:/usr/src/debwrt
$ svn update
svn: OPTIONS of 'https://svn.debwrt.net/debwrt/trunk': could not connect to server (https://svn.debwrt.net)
stappers@inertia:/usr/src/debwrt
$ 

comment:3 Changed 12 years ago by stappers

Currently is SVN available.

stappers@inertia:/usr/src/debwrt
$ svn update
At revision 188.
stappers@inertia:/usr/src/debwrt
$ date
di mrt 29 20:12:55 CEST 2011
stappers@inertia:/usr/src/debwrt
$ svn update
At revision 188.
stappers@inertia:/usr/src/debwrt
$ 

Leaving ticket open for two reasons:

  • To express my concern.
  • Hoping for some information about why the intermissions do / did occure.

And a thrid reason:

  • Having a place where SVN server hick-ups can be reported.

comment:4 Changed 12 years ago by stappers

Another SVN issue, probably worth another ticket, but reporting it here ...

stappers@viggo:/usr/src
$ rm -rf debWRT
stappers@viggo:/usr/src
$ svn checkout https://svn.debwrt.net/debwrt/trunk !$
svn checkout https://svn.debwrt.net/debwrt/trunk debWRT
Error validating server certificate for 'https://svn.debwrt.net:443':
 - The certificate is not issued by a trusted authority. Use the
   fingerprint to validate the certificate manually!
 - The certificate hostname does not match.
Certificate information:
 - Hostname: localhost.localdomain
 - Valid: from Mon, 14 Jun 2010 23:06:55 GMT until Thu, 11 Jun 2020 23:06:55 GMT
 - Issuer: localhost.localdomain
 - Fingerprint: ff:83:c6:ff:2b:ef:f0:94:3d:c1:60:a4:2f:1d:6c:ea:9c:45:05:c4
(R)eject, accept (t)emporarily or accept (p)ermanently? t
svn: Server sent unexpected return value (405 Method Not Allowed) in response to PROPFIND request for '/debwrt/trunk'
stappers@viggo:/usr/src
$ svn checkout https://svn.debwrt.net/debwrt/trunk debWRT
Error validating server certificate for 'https://svn.debwrt.net:443':
 - The certificate is not issued by a trusted authority. Use the
   fingerprint to validate the certificate manually!
 - The certificate hostname does not match.
Certificate information:
 - Hostname: localhost.localdomain
 - Valid: from Mon, 14 Jun 2010 23:06:55 GMT until Thu, 11 Jun 2020 23:06:55 GMT
 - Issuer: localhost.localdomain
 - Fingerprint: ff:83:c6:ff:2b:ef:f0:94:3d:c1:60:a4:2f:1d:6c:ea:9c:45:05:c4
(R)eject, accept (t)emporarily or accept (p)ermanently? t
svn: Server sent unexpected return value (405 Method Not Allowed) in response to PROPFIND request for '/debwrt/trunk'
stappers@viggo:/usr/src
$ 

comment:5 Changed 12 years ago by stappers

svn update not working

stappers@inertia:/usr/src/debWRT/debian/package/hostapd/debian
$ patch < 79
patching file hostapd.init
stappers@inertia:/usr/src/debWRT/debian/package/hostapd/debian
$ svn update
svn: OPTIONS of 'https://svn.debwrt.net/debwrt/trunk/debian/package/hostapd/debian': could not connect to server (https://svn.debwrt.net)
stappers@inertia:/usr/src/debWRT/debian/package/hostapd/debian
$ date
do mrt 31 22:56:44 CEST 2011
stappers@inertia:/usr/src/debWRT/debian/package/hostapd/debian
$ 

No joy ...

comment:6 Changed 12 years ago by amain

  • Resolution set to worksforme
  • Status changed from reopened to closed

SVN seems to work just fine. Checked a fresh and clean svn co and a svn commit. "could not connect to server (https://svn.debwrt.net)" may indicate local network problems. If problem persists and is for sure not a local / internet problem, please re-open. Please do some testing from a second location if you have one. Use ping, mtr, etc.

About the SSL cert problem: I use "(p)ermanently and see no problems.

For now: closing as worksforme / can't replicate problem

comment:7 Changed 12 years ago by stappers

Over here is the problem still reproducable, it doesn't work for me.

stappers@viggo:/usr/src
$ rm -rf debwrt
stappers@viggo:/usr/src
$ svn checkout https://stappers@svn.debwrt.net/debwrt/trunk debwrt
svn: Server sent unexpected return value (405 Method Not Allowed) in response to PROPFIND request for '/debwrt/trunk'
stappers@viggo:/usr/src
$ svn checkout --force https://stappers@svn.debwrt.net/debwrt/trunk debwrt
svn: Server sent unexpected return value (405 Method Not Allowed) in response to PROPFIND request for '/debwrt/trunk'
stappers@viggo:/usr/src
$ 

Could my IPv4 address in some way be a special one?
Could we be dealing with some left-overs??

.... oh crap ....

stappers@viggo:/usr/src
$ host dev.debwrt.net
dev.debwrt.net has address 81.171.37.249
stappers@viggo:/usr/src
$ ping svn.debwrt.net
PING svn.debwrt.net (83.119.137.172) 56(84) bytes of data.
64 bytes from svn.debwrt.net (83.119.137.172): icmp_seq=1 ttl=56 time=38.7 ms
64 bytes from svn.debwrt.net (83.119.137.172): icmp_seq=2 ttl=56 time=37.8 ms
64 bytes from svn.debwrt.net (83.119.137.172): icmp_seq=3 ttl=56 time=37.6 ms
^C
--- svn.debwrt.net ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 37.643/38.065/38.745/0.485 ms
stappers@viggo:/usr/src
$ 

Modified my /etc/hosts

stappers@viggo:/usr/src
$ ping -w 2 svn.debwrt.net
PING svn.debwrt.net (81.171.37.249) 56(84) bytes of data.
64 bytes from 81.171.37.249: icmp_seq=1 ttl=58 time=19.6 ms

--- svn.debwrt.net ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 19.657/19.657/19.657/0.000 ms
stappers@viggo:/usr/src
$ svn checkout https://stappers@svn.debwrt.net/debwrt/trunk debwrt | tail -n 3
Error validating server certificate for 'https://svn.debwrt.net:443':
 - The certificate is not issued by a trusted authority. Use the
   fingerprint to validate the certificate manually!
 - The certificate hostname does not match.
Certificate information:
 - Hostname: dev.debwrt.net
 - Valid: from Sat, 19 Feb 2011 21:01:19 GMT until Tue, 16 Feb 2021 21:01:19 GMT
 - Issuer: dev.debwrt.net
 - Fingerprint: 15:dd:03:49:ee:63:0f:1c:a8:e3:8e:24:20:cc:1c:25:24:75:c4:ce
(R)eject, accept (t)emporarily or accept (p)ermanently? t
A    debwrt/openwrt/openwrt-deliver.mk
 U   debwrt
Checked out revision 198.
stappers@viggo:/usr/src
$ 

So, works for me also :-/

comment:8 Changed 9 years ago by MacMillan

It is reported that, <a href="http://gagawatch.amigasa.jp"><b>激安腕時計メンズ</b></a>

GAGA supervise <a href="http://gagawatch.ganriki.net"><b>ガガミラノ アウトレット</b></a>
15 December, with the age complete hundred sites on-line starting at the unvaried <a href="http://gagawatch.client.jp"><b>gaga 時計</b></a>

while, as the astounding's <a href="http://gagawatch.gejigeji.jp"><b>ガガミラノ 正規</b></a>

day one internet supervise highlights of the key <a href="http://gagawatch.amigasa.jp"><b>ガガミラノ 価格</b></a>
compel products, GAGA series includes a pure of ten models, <a href="http://gagawatch.bufsiz.jp"><b>腕時計 ガガミラノ</b></a>
immense coverage of jet-black, pink, yellow, white, glistening, rose gold six important mainstream color. <a href="http://gagawatch.bufsiz.jp"><b>ガガミラノ 48mm</b></a>
Interim, in figure with the "leather strap" and "buttress clutches district" two kinds of elegance sophisticatedness, fully embodies the color and fashionableness of Brand with, so the <a href="http://gagawatch.client.jp"><b>ガガミラノ 腕時計</b></a>
craze elements junior to control. For now, Gaga mind <a href="http://gagawatch.ashigaru.jp"><b>ミラノ ガガ</b></a>
also built nowadays mainstream America was gifted Japanese Townsman 2035 quartz action, and strengthening crystal opera-glasses reflector of the <a href="http://gagawatch.client.jp"><b>時計 ガガミラノ</b></a>
what indeed happened profane, fully guarantee the outcome's durability properties. <a href="http://gagawatch.biroudo.jp"><b>格安腕時計</b></a>
Opportunity on the engender of <a href="http://gagawatch.gejigeji.jp"><b>ガガミラノ アウトレット</b></a>
undistracted hundred on-line, with the "twofold egg" topic,gagawatch.ashigaru.jp held a "Grand Toe, on-line carnival, dual egg deferential" strapping event <a href="http://gagawatch.ganriki.net"><b>時計 gaga</b></a>
promotional activities during the things turned antiquated, <a href="http://gagawatch.gejigeji.jp"><b>アウトレット ミラノ</b></a>

including the 180 series, including a kindly of retail GAGA has active discount. Accepted Links: gagawatch.amigasa.jp

Add Comment

Modify Ticket

Action
as closed The owner will remain amain.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.