Ignore:
Timestamp:
Jan 15, 2017, 2:26:01 PM (2 years ago)
Author:
amain
Message:

native: erlite native kernel compile support

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/config/cross/config.in

    r694 r902  
    1818# Kconfig documentation: http://lxr.linux.no/#linux+v2.6.34.1/Documentation/kbuild/kconfig-language.txt
    1919
     20config DEBIAN_BUILDENV_RELEASE
     21        string
     22        default "sid"     if DEBIAN_BUILDENV_RELEASE_SID
     23        default "stretch" if DEBIAN_BUILDENV_RELEASE_STRETCH
     24        default "jessie"  if DEBIAN_BUILDENV_RELEASE_JESSIE
     25        default "wheezy"  if DEBIAN_BUILDENV_RELEASE_WHEEZY
     26        default "squeeze" if DEBIAN_BUILDENV_RELEASE_SQUEEZE
     27        default "lenny"   if DEBIAN_BUILDENV_RELEASE_LENNY
     28        default "sid"     if DEBIAN_BUILDENV_RELEASE_SID
     29        default "none"
     30
    2031menuconfig DEBWRT_CROSS
    21     bool "Debian cross build environment (optional)"
     32    bool "Debian cross build environment"
    2233    default n
    2334    help
     
    2536      no need anymore to setup the Debian cross build environment and cross build the
    2637      DebWrt debian packages.
     38 
     39    if DEBWRT_CROSS 
     40        choice
     41            prompt "Debian Release"
     42            default DEBIAN_BUILDENV_RELEASE_JESSIE
     43            help
     44              Debian release
     45
     46            config DEBIAN_BUILDENV_RELEASE_SID
     47                bool
     48                prompt "Sid"
     49
     50            config DEBIAN_BUILDENV_RELEASE_STRETCH
     51                bool
     52                prompt "Stretch"
     53
     54            config DEBIAN_BUILDENV_RELEASE_JESSIE
     55                bool
     56                prompt "Jessie"
     57
     58            config DEBIAN_BUILDENV_RELEASE_WHEEZY
     59                bool
     60                prompt "Wheezy"
     61
     62            config DEBIAN_BUILDENV_RELEASE_SQUEEZE
     63                bool
     64                prompt "Squeeze (depricated - may not work)"
     65
     66            config DEBIAN_BUILDENV_RELEASE_LENNY
     67                bool
     68                prompt "Lenny (depricated - may not work)"
     69
     70        endchoice
    2771       
    28     config DEBIAN_BUILDENV_REPOSITORY
    29             string "Debian Repository" if DEBWRT_CROSS
    30             default "http://ftp.debian.org/debian"
    31             help
    32               Specify the Debian Repository used to set up de Debian Cross-Compile chroot
    33               environment and used to install Debian chroot for the target architecture.
     72        config DEBIAN_BUILDENV_REPOSITORY
     73        string "Debian Repository"
     74        default "http://ftp.debian.org/debian"
     75        help
     76          Specify the Debian Repository used to set up de Debian Cross-Compile chroot
     77          environment and used to install Debian chroot for the target architecture.
    3478
    35     config EMDEBIAN_BUILDENV_REPOSITORY
    36             string "Emdebian Repository" if DEBWRT_CROSS
     79        config DEBIAN_BUILDENV_SETUP_EMDEBIAN
     80            bool "Install Emdebian (obsolete)"
     81            default n
     82
     83        config DEBIAN_BUILDENV_SETUP_QEMU
     84            bool "Install Qemu (obsolete)"
     85            default n
     86
     87        config EMDEBIAN_BUILDENV_REPOSITORY
     88            string "Emdebian Repository" if DEBIAN_BUILDENV_SETUP_EMDEBIAN
    3789            default "http://www.emdebian.org/debian"
    3890            help
     
    4092              environment and used to install Debian chroot for the target architecture.
    4193
    42     config DEBIAN_BUILDENV_INCLUDE_PACKAGES
    43             string "Additional packages" if DEBWRT_CROSS
     94        config DEBIAN_BUILDENV_INCLUDE_PACKAGES
     95            string "Additional packages"
    4496            default "file,less,strace,sudo"
    4597            help
     
    48100              debootstrapped chrooted Debian sid installation.
    49101
    50     config DEBIAN_BUILDENV_QEMU_VERSION
    51             string "Qemu version" if DEBWRT_CROSS
     102        config DEBIAN_BUILDENV_QEMU_VERSION
     103            string "Qemu version" if DEBIAN_BUILDENV_SETUP_QEMU
    52104            default "2.4.0.1"
    53105            help
    54106              At least 0.12.2 is needed for mips targets.
     107    endif
    55108
     109
Note: See TracChangeset for help on using the changeset viewer.