source: trunk/debian/package/debwrt-net/debian/rules @ 292

Last change on this file since 292 was 292, checked in by amain, 12 years ago

debwrt-net package added: this package will contain all DebWrt networking configuration

  • Property svn:executable set to *
File size: 1.2 KB
Line 
1#!/usr/bin/make -f
2
3export DH_VERBOSE=1
4INSTDIR=debian/debwrt-net
5
6%:
7        dh $@ 
8
9override_dh_auto_install:
10        install -o root -g root -d $(INSTDIR)/usr/sbin
11        install -o root -g root -d $(INSTDIR)/etc/network
12        install -o root -g root -d $(INSTDIR)/etc/firewall
13        install -o root -g root -d $(INSTDIR)/etc/hostapd
14        install -o root -g root -d $(INSTDIR)/etc/modprobe.d
15        install -o root -g root -d $(INSTDIR)/etc/sysctl.d
16        install -o root -g root -d $(INSTDIR)/usr/share/doc/debwrt-net
17        install -o root -g root -m 644 usr/sbin/pciunbind              $(INSTDIR)/usr/sbin/pciunbind
18        install -o root -g root -m 644 etc/network/interfaces.broadcom $(INSTDIR)/etc/network/interfaces.broadcom
19        install -o root -g root -m 644 etc/modprobe.d/wl.conf          $(INSTDIR)/etc/modprobe.d/wl.conf
20        install -o root -g root -m 644 etc/modprobe.d/b43.conf         $(INSTDIR)/etc/modprobe.d/b43.conf
21        install -o root -g root -m 644 etc/firewall/firewall.sh        $(INSTDIR)/etc/firewall/firewall.sh
22        install -o root -g root -m 644 etc/sysctl.d/debwrt.conf        $(INSTDIR)/etc/sysctl.d/debwrt.conf
23        install -o root -g root -m 644 usr/share/doc/debwrt-net/nas    $(INSTDIR)/usr/share/doc/debwrt-net/nas
Note: See TracBrowser for help on using the repository browser.