[76] | 1 | # DebWrt - Debian on Embedded devices |
---|
| 2 | # |
---|
| 3 | # Copyright (C) 2010 Johan van Zoomeren <amain@debwrt.net> |
---|
| 4 | # |
---|
| 5 | # This program is free software: you can redistribute it and/or modify |
---|
| 6 | # it under the terms of the GNU General Public License as published by |
---|
| 7 | # the Free Software Foundation, either version 3 of the License, or |
---|
| 8 | # (at your option) any later version. |
---|
| 9 | # |
---|
| 10 | # This program is distributed in the hope that it will be useful, |
---|
| 11 | # but WITHOUT ANY WARRANTY; without even the implied warranty of |
---|
| 12 | # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the |
---|
| 13 | # GNU General Public License for more details. |
---|
| 14 | # |
---|
| 15 | # You should have received a copy of the GNU General Public License |
---|
| 16 | # along with this program. If not, see <http://www.gnu.org/licenses/>. |
---|
| 17 | |
---|
| 18 | debian/package/robocfg: debian/package/robocfg/deliver |
---|
| 19 | touch $@ |
---|
| 20 | |
---|
| 21 | debian/package/robocfg/deliver: debian/package/robocfg/build |
---|
| 22 | mkdir -p ${INSTALL_DIR_DEBIAN_PACKAGES} |
---|
| 23 | cp -rav $(DEBIAN_BUILD_DIR)/usr/src/robocfg/*.deb ${INSTALL_DIR_DEBIAN_PACKAGES} |
---|
| 24 | cp -rav $(DEBIAN_BUILD_DIR)/usr/src/robocfg/*.tar.gz ${INSTALL_DIR_DEBIAN_PACKAGES} |
---|
| 25 | cp -rav $(DEBIAN_BUILD_DIR)/usr/src/robocfg/*.dsc ${INSTALL_DIR_DEBIAN_PACKAGES} |
---|
| 26 | cp -rav $(DEBIAN_BUILD_DIR)/usr/src/robocfg/*.changes ${INSTALL_DIR_DEBIAN_PACKAGES} |
---|
| 27 | touch $@ |
---|
| 28 | |
---|
| 29 | debian/package/robocfg/build: debian/package/robocfg/prepare debian/package/libnl |
---|
| 30 | $(CHROOT_USER) bash -c "cd /usr/src/robocfg; export ARCH=$(TARGET_ARCH); ./build.sh" |
---|
| 31 | touch $@ |
---|
| 32 | |
---|
| 33 | debian/package/robocfg/prepare: debian/buildenv/create |
---|
| 34 | rm -rf $(DEBIAN_BUILD_DIR)/usr/src/robocfg |
---|
| 35 | mkdir -p $(DEBIAN_BUILD_DIR)/usr/src/robocfg |
---|
| 36 | if [ -d $(DEBIAN_PACKAGES_DIR)/robocfg/debian ]; then \ |
---|
| 37 | cp -ar $(DEBIAN_PACKAGES_DIR)/robocfg/debian $(DEBIAN_BUILD_DIR)/usr/src/robocfg; \ |
---|
| 38 | fi |
---|
| 39 | cp -ar $(DEBIAN_PACKAGES_DIR)/robocfg/build.sh $(DEBIAN_BUILD_DIR)/usr/src/robocfg |
---|
| 40 | touch $@ |
---|
| 41 | |
---|
| 42 | debian/package/robocfg/clean: |
---|
| 43 | rm -f debian/package/robocfg/build |
---|
| 44 | rm -f debian/package/robocfg/prepare |
---|
| 45 | rm -f debian/package/robocfg/deliver |
---|
| 46 | |
---|