source: debwrt/trunk/debian/package/libnl-tiny/build.mk @ 199

Last change on this file since 199 was 199, checked in by stappers, 12 years ago

Introducing DEBWRT_PKGLST

this adds the variable DEBWRT_PKGLST in various make files
in and under the debian/package directory

File size: 2.2 KB
RevLine 
[125]1# DebWrt - Debian on Embedded devices
2#
3# Copyright (C) 2010 Johan van Zoomeren <amain@debwrt.net>
4#
5# This program is free software: you can redistribute it and/or modify
6# it under the terms of the GNU General Public License as published by
7# the Free Software Foundation, either version 3 of the License, or
8# (at your option) any later version.
9#
10# This program is distributed in the hope that it will be useful,
11# but WITHOUT ANY WARRANTY; without even the implied warranty of
12# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
13# GNU General Public License for more details.
14#
15# You should have received a copy of the GNU General Public License
16# along with this program.  If not, see <http://www.gnu.org/licenses/>.
17
[199]18DEBWRT_PKGLST:=$(DEBWRT_PKGLST) debian/package/libnl-tiny
19
[125]20debian/package/libnl-tiny: debian/package/libnl-tiny/deliver
21        touch $@
22
23debian/package/libnl-tiny/deliver: debian/package/libnl-tiny/build
24        mkdir -p ${INSTALL_DIR_DEBIAN_PACKAGES}
25        cp -rav $(DEBIAN_BUILD_DIR)/usr/src/libnl-tiny/*.deb ${INSTALL_DIR_DEBIAN_PACKAGES}
26        cp -rav $(DEBIAN_BUILD_DIR)/usr/src/libnl-tiny/*.tar.gz ${INSTALL_DIR_DEBIAN_PACKAGES}
27        cp -rav $(DEBIAN_BUILD_DIR)/usr/src/libnl-tiny/*.dsc ${INSTALL_DIR_DEBIAN_PACKAGES}
28        cp -rav $(DEBIAN_BUILD_DIR)/usr/src/libnl-tiny/*.changes ${INSTALL_DIR_DEBIAN_PACKAGES}
29        touch $@
30
31debian/package/libnl-tiny/build: debian/package/libnl-tiny/prepare debian/package/libnl
32        $(CHROOT_USER) bash -c "cd /usr/src/libnl-tiny; export ARCH=$(TARGET_ARCH); ./build.sh"
33        touch $@
34
35debian/package/libnl-tiny/prepare: debian/buildenv/create
36        rm -rf   $(DEBIAN_BUILD_DIR)/usr/src/libnl-tiny
37        mkdir -p $(DEBIAN_BUILD_DIR)/usr/src/libnl-tiny
38        if [ -d $(DEBIAN_PACKAGES_DIR)/libnl-tiny/debian ]; then \
39            cp -ar $(DEBIAN_PACKAGES_DIR)/libnl-tiny/debian $(DEBIAN_BUILD_DIR)/usr/src/libnl-tiny; \
40        fi
41        if [ -d $(DEBIAN_PACKAGES_DIR)/libnl-tiny/patches ]; then \
42                cp -arv $(DEBIAN_PACKAGES_DIR)/libnl-tiny/patches $(DEBIAN_BUILD_DIR)/usr/src/libnl-tiny; \
43        fi
44        cp -ar $(DEBIAN_PACKAGES_DIR)/libnl-tiny/build.sh $(DEBIAN_BUILD_DIR)/usr/src/libnl-tiny
45        touch $@
46
47debian/package/libnl-tiny/clean:
48        rm -f debian/package/libnl-tiny/build
49        rm -f debian/package/libnl-tiny/prepare
50        rm -f debian/package/libnl-tiny/deliver
51
Note: See TracBrowser for help on using the repository browser.