source: branches/contrib/openwrt/patches/all/012_disable_all_openwrt_packages @ 430

Last change on this file since 430 was 430, checked in by ehem, 7 years ago

Switch to using -p1 for applying OpenWRT patches. This matches the way most
things are distributed as patches, even though not needed for DebWRT.

File size: 828 bytes
Line 
1--- openwrt/include/toplevel.mk.org     2010-01-02 00:28:44.000000000 +0100
2+++ openwrt/include/toplevel.mk 2010-01-02 00:14:07.000000000 +0100
3@@ -49,6 +49,11 @@
4                f=tmp/.$${type}info; t=tmp/.config-$${type}.in; \
5                [ "$$t" -nt "$$f" ] || ./scripts/metadata.pl $${type}_config "$$f" > "$$t" || { rm -f "$$t"; echo "Failed to build $$t"; false; break; }; \
6        done
7+       # DebWrt: we don't need to build any packages by default, so we disable them
8+       #         all. This allows us to have fine control over which packages we
9+       #         want to build.
10+       sed 's/default [ynm]/default n/g' tmp/.config-package.in > tmp/.config-package.in.new
11+       mv tmp/.config-package.in.new tmp/.config-package.in
12        ./scripts/metadata.pl package_mk tmp/.packageinfo > tmp/.packagedeps || { rm -f tmp/.packagedeps; false; }
13        touch $(TOPDIR)/tmp/.build
14 
Note: See TracBrowser for help on using the repository browser.